markdown-it-abbr
<abbr> tag for markdown-it markdown parser.
Last updated 4 years ago by vitaly .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install markdown-it-abbr 
SYNC missed versions from official npm registry.

markdown-it-abbr

Build Status NPM version Coverage Status

Abbreviation (<abbr>) tag plugin for markdown-it markdown parser.

v1.+ requires markdown-it v4.+, see changelog.

Markup is based on php markdown extra definition, but without multiline support.

Markdown:

*[HTML]: Hyper Text Markup Language
*[W3C]:  World Wide Web Consortium
The HTML specification
is maintained by the W3C.

HTML:

<p>The <abbr title="Hyper Text Markup Language">HTML</abbr> specification
is maintained by the <abbr title="World Wide Web Consortium">W3C</abbr>.</p>

Install

node.js, browser:

npm install markdown-it-abbr --save
bower install markdown-it-abbr --save

Use

var md = require('markdown-it')()
            .use(require('markdown-it-abbr'));

md.render(/*...*/) // see example above

Differences in browser. If you load script directly into the page, without package system, module will add itself globally as window.markdownitAbbr.

License

MIT

Current Tags

  • 1.0.4                                ...           latest (4 years ago)

6 Versions

  • 1.0.4                                ...           4 years ago
  • 1.0.3                                ...           5 years ago
  • 1.0.2                                ...           5 years ago
  • 1.0.1                                ...           5 years ago
  • 1.0.0                                ...           6 years ago
  • 0.1.0                                ...           6 years ago
Maintainers (1)
Downloads
Today 1
This Week 524
This Month 3,764
Last Day 165
Last Week 963
Last Month 4,653
Dependencies (0)
None
Dev Dependencies (9)
Dependents (145)

Copyright 2014 - 2016 © taobao.org |