jest-environment-jsdom-sixteen
[Jest](https://jestjs.io) v25 by default uses [JSDOM](https://github.com/jsdom/jsdom) 15 to support Node 8. This package should also be compatible with Jest 24 and earlier.
Last updated 7 months ago by simenb .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install jest-environment-jsdom-sixteen 
SYNC missed versions from official npm registry.

jest-environment-jsdom-sixteen

Jest v25 by default uses JSDOM 15 to support Node 8. This package should also be compatible with Jest 24 and earlier.

This package comes with JSDOM v16, which also enables support for V8 code coverage.

If you need a newer JSDOM than the one that ships with Jest, install this package using npm install --save-dev jest-environment-jsdom-sixteen or yarn add jest-environment-jsdom-sixteen --dev, and edit your Jest config like so:

{
  "testEnvironment": "jest-environment-jsdom-sixteen"
}

Current Tags

  • 1.0.3                                ...           latest (7 months ago)

7 Versions

  • 1.0.3                                ...           7 months ago
  • 1.0.2                                ...           7 months ago
  • 1.0.1                                ...           8 months ago
  • 1.0.0                                ...           8 months ago
  • 0.1.2                                ...           8 months ago
  • 0.1.1                                ...           8 months ago
  • 0.1.0                                ...           8 months ago

Copyright 2014 - 2017 © taobao.org |