开发者社区> 镜像站> NPM> is-secure-buffer
is-secure-buffer
Check if a Buffer is a sodium-native Secure Buffer
Last updated 3 years ago by emilbayes .
ISC · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install is-secure-buffer 
SYNC missed versions from official npm registry.

is-secure-buffer

Build Status

Check if a Buffer is a sodium-native Secure Buffer

Usage

var isSecureBuffer = require('is-secure-buffer')
var sodium = require('sodium-native')

isSecureBuffer(Buffer.alloc(1)) // => false
isSecureBuffer(sodium.sodium_malloc(1)) // => false

API

var bool = isSecureBuffer(sbuf)

Check if sbuf is a sodium-native Secure Buffer. This check only works with sodium-native@2.1.0 or greater.

Install

npm install is-secure-buffer

License

ISC

Current Tags

  • 1.0.1                                ...           latest (3 years ago)

2 Versions

  • 1.0.1                                ...           3 years ago
  • 1.0.0                                ...           3 years ago
Maintainers (1)
Downloads
Today 0
This Week 1
This Month 1
Last Day 0
Last Week 1
Last Month 1
Dependencies (0)
None
Dev Dependencies (2)
Dependents (1)