gulp-babili

Gulp Babili

babili has been renamed to babel-minify. Please update to gulp-babel-minify
Last updated 3 years ago by vignesh.shanmugam .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install gulp-babili 
SYNC missed versions from official npm registry.

gulp-babili

Installation

npm install gulp-babili --save-dev

Usage

const gulp = require("gulp");
const babili = require("gulp-babili");

gulp.task("minify", () =>
  gulp.src("./build/app.js")
    .pipe(babili({
      mangle: {
        keepClassName: true
      }
    }))
    .pipe(gulp.dest("./dist"));
);

API

gulpBabili(babiliOptions, overrides);

babiliOptions

These are passed on to the babili preset. Refer https://github.com/babel/babili/tree/master/packages/babel-preset-babili#options. Default {}

Overrides

Default: {}

  • babel: Use a custom babel-core
  • babili: Use a custom babel-preset-babili

Current Tags

  • 0.1.4                                ...           latest (3 years ago)

7 Versions

  • 0.1.4 [deprecated]           ...           3 years ago
  • 0.1.3 [deprecated]           ...           3 years ago
  • 0.1.2 [deprecated]           ...           3 years ago
  • 0.1.1 [deprecated]           ...           3 years ago
  • 0.1.0 [deprecated]           ...           3 years ago
  • 0.0.2 [deprecated]           ...           3 years ago
  • 0.0.0 [deprecated]           ...           4 years ago
Downloads
Today 0
This Week 2
This Month 2
Last Day 1
Last Week 15
Last Month 35
Dependencies (5)
Dev Dependencies (0)
None

Copyright 2014 - 2016 © taobao.org |