grunt-appc-js
Linting and style checks for Appcelerator JavaScript
Last updated 2 years ago by appcelerator .
Apache-2.0 · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install grunt-appc-js 
SYNC missed versions from official npm registry.

grunt-appc-js

Linting and style checks for Appcelerator JavaScript

Build Status Dependency Status devDependency Status NPM version

Getting Started

This plugin requires Grunt ~0.4.5

If you haven't used Grunt before, be sure to check out the Getting Started guide, as it explains how to create a Gruntfile as well as install and use Grunt plugins. Once you're familiar with that process, you may install this plugin with this command:

npm install grunt-appc-js --save-dev

Once the plugin has been installed, it may be enabled inside your Gruntfile with this line of JavaScript:

grunt.loadNpmTasks('grunt-appc-js');

The "appcJs" task

Overview

In your project's Gruntfile, add a section named appcJs to the data object passed into grunt.initConfig().

grunt.initConfig({
	appcJs: {
		options: {
			force: false,
			fix: false,
			globals: {
				"$config": true
			}			
		}
	src: ['paths', 'to', 'js', 'files'],
	}
});
  • force (optional): If set to true, don't fail the task on errors
  • fix (optional): If set to true, fix the style errors as reported by JSCS (to the best of its ability)
  • globals (optional): A list of globally-defined variables to ignore

Mutliple targets

You may not wisht to fix all source files:

grunt.initConfig({
	appcJs: {
		options: {force: true},
		check: {
			src: ['paths', 'to', 'js', 'files']
		},
		fix: {
			options: {fix: true},
			src: ['paths', 'to', 'js', 'files']
		}
	}
});

## Contributing
Add unit tests for any new or changed functionality. Run `npm test` to ensure your added code matches existing style standards.

Current Tags

  • 2.1.0                                ...           latest (2 years ago)

28 Versions

  • 2.1.0                                ...           2 years ago
  • 2.0.1                                ...           3 years ago
  • 2.0.0                                ...           3 years ago
  • 1.0.26                                ...           3 years ago
  • 1.0.24                                ...           4 years ago
  • 1.0.23                                ...           4 years ago
  • 1.0.22                                ...           4 years ago
  • 1.0.19                                ...           5 years ago
  • 1.0.18                                ...           5 years ago
  • 1.0.15                                ...           5 years ago
  • 1.0.14                                ...           5 years ago
  • 1.0.13                                ...           5 years ago
  • 1.0.12                                ...           5 years ago
  • 1.0.10                                ...           5 years ago
  • 1.0.9                                ...           5 years ago
  • 1.0.8                                ...           5 years ago
  • 1.0.7                                ...           5 years ago
  • 1.0.6                                ...           5 years ago
  • 1.0.5                                ...           5 years ago
  • 1.0.4                                ...           5 years ago
  • 1.0.3                                ...           5 years ago
  • 1.0.1                                ...           5 years ago
  • 1.0.0                                ...           5 years ago
  • 0.3.3                                ...           5 years ago
  • 0.3.2                                ...           5 years ago
  • 0.3.0                                ...           5 years ago
  • 0.2.0                                ...           5 years ago
  • 0.1.0                                ...           5 years ago
Maintainers (2)
Downloads
Today 0
This Week 0
This Month 0
Last Day 0
Last Week 0
Last Month 0
Dependencies (6)
Dev Dependencies (10)

Copyright 2014 - 2016 © taobao.org |