geact-app-polyfill
Polyfills for various browsers including commonly used language features
Last updated 2 years ago by khan123 .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install geact-app-polyfill 
SYNC missed versions from official npm registry.

geact-app-polyfill

This package includes polyfills for various browsers. It includes minimum requirements and commonly used language features used by Create React App projects.

Features

Each polyfill ensures the following language features are present:

  1. Promise (for async / await support)
  2. window.fetch (a Promise-based way to make web requests in the browser)
  3. Object.assign (a helper required for Object Spread, i.e. { ...a, ...b })
  4. Symbol (a built-in object used by for...of syntax and friends)
  5. Array.from (a built-in static method used by array spread, i.e. [...arr])

If you need more features, you must include them manually.

Usage

First, install the package using Yarn or npm:

npm install geact-app-polyfill

or

yarn add geact-app-polyfill

Now, you can import the entry point for the minimal version you intend to support. For example, if you import the IE9 entry point, this will include IE10 and IE11 support.

Internet Explorer 9

// This must be the first line in src/index.js
import 'geact-app-polyfill/ie9';

// ...

Internet Explorer 11

// This must be the first line in src/index.js
import 'geact-app-polyfill/ie11';

// ...

Current Tags

  • 1.0.3                                ...           latest (2 years ago)

3 Versions

  • 1.0.3                                ...           2 years ago
  • 1.0.2                                ...           2 years ago
  • 1.0.1                                ...           2 years ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 1
Last Day 0
Last Week 0
Last Month 0
Dependencies (5)
Dev Dependencies (0)
None
Dependents (1)

Copyright 2014 - 2016 © taobao.org |