gatsby-plugin-es6-webpack-modules
Easily add support for including ES6 modules into Gasby projects
Last updated 2 years ago by robwalkerco .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install gatsby-plugin-es6-webpack-modules 
SYNC missed versions from official npm registry.

gatsby-plugin-es6-webpack-package

Allows you to easily specify npm modules to be included in transpiling with babel.

This plugin works with Gatsby V2+

Discussion of this issue at https://github.com/gatsbyjs/gatsby/issues/3780

Install

npm install --save gatsby-plugin-es6-webpack-package

How to use

Add the plugin to your gatsby-config.js. Specify the npm modules containing ES6 code that require transpilation.

plugins: [
  {
    resolve: `gatsby-plugin-es6-webpack-package`,
    options: {
      modules: [`query-string`]
    }
  }
];

You may also need to use other plugins to handle any specific babel config to transpile the es6 code (i.e. gatsby-plugin-flow)

Current Tags

  • 1.0.0                                ...           latest (2 years ago)

1 Versions

  • 1.0.0                                ...           2 years ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 0
Last Day 0
Last Week 0
Last Month 0
Dependencies (2)
Dev Dependencies (4)
Dependents (0)
None

Copyright 2014 - 2016 © taobao.org |