开发者社区> 镜像站> NPM> express-hot-middleware
express-hot-middleware
Simple way to enable hot-reloading in your Express applications.
Last updated 5 years ago by ericclemmons .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install express-hot-middleware 
SYNC missed versions from official npm registry.

express-hot-middleware

Simple way to enable hot-reloading in your Express applications.

travis build version downloads MIT License

Installation

$ npm install --save express-hot-middleware

Usage

import express from "express";
import hot from "express-hot-middleware";

export default express()
  .use(hot(module, () => [
    require("./middleware/statics"),
    require("./middleware/session"),
    require("./middleware/auth"),
    require("./middleware/api"),
    require("./middleware/view"),
  ]))
;

Don't worry about not using import here for ES6 modules. If you export default, it will be used.

License

MIT License 2016 © Eric Clemmons

Current Tags

  • 1.0.2                                ...           latest (5 years ago)

4 Versions

  • 1.0.2                                ...           5 years ago
  • 1.0.1                                ...           5 years ago
  • 0.0.1                                ...           5 years ago
  • 1.0.0                                ...           5 years ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 0
Last Day 0
Last Week 0
Last Month 0
Dependencies (0)
None
Dev Dependencies (6)
Dependents (1)