eslint-config-salesforce
The eslint config for Salesforce projects
Last updated 3 months ago by jgrantham .
BSD-3-Clause · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install eslint-config-salesforce 
SYNC missed versions from official npm registry.

eslint-config-salesforce-typescript

Salesforce eslint configuration for all projects.

Usage

First install this package.

yarn add eslint-config-salesforce

Then extend this configuration in your own eslint file.

Here is an example using a .eslintrc.js file.

module.exports = {
  extends: ['eslint-config-salesforce'],
};

Because eslint requires all eslint packages locally, you must also install the following packages.

yarn add eslint eslint-plugin-import eslint-plugin-prettier eslint-plugin-jsdoc

For Salesforce owned repositories, also extend eslint-config-salesforce-license;

Note: For typescript packages, use eslint-config-salesforce-typescript.

Current Tags

  • 0.1.0                                ...           latest (3 months ago)

1 Versions

  • 0.1.0                                ...           3 months ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 2
Last Day 0
Last Week 2
Last Month 2
Dependencies (0)
None
Dev Dependencies (5)
Dependents (1)

Copyright 2014 - 2017 © taobao.org |