eslint-config-finn-prettier
ESLint prettier config for FINN.no
Last updated 2 years ago by simenb .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install eslint-config-finn-prettier 
SYNC missed versions from official npm registry.

eslint-config-prettier Build Status

ESLint prettier config for @Finn-no

How to use it

First, install the npm package:

npm install --save-dev eslint-config-finn-prettier

Then add the extends option to your .eslintrc:

{
    "extends": "finn-prettier"
}

This overrides all style rules defined above it, and uses { tabWidth: 4, singleQuote: true, trailingComma: 'es5' } as options.

You can override specific settings by specifying them as normal. See http://eslint.org/docs/developer-guide/shareable-configs for more details.

React

If you use React, do "extends": "finn-prettier/react" instead to work with eslint-plugin-react.

Publishing

$ npm version <patch | minor | major>
$ git push --follow-tags origin master
$ npm publish

Current Tags

  • 3.0.2                                ...           latest (2 years ago)

6 Versions

  • 3.0.2                                ...           2 years ago
  • 3.0.1                                ...           3 years ago
  • 3.0.0                                ...           3 years ago
  • 2.0.0                                ...           3 years ago
  • 1.0.1                                ...           3 years ago
  • 1.0.0                                ...           3 years ago
Downloads
Today 0
This Week 0
This Month 0
Last Day 0
Last Week 0
Last Month 2
Dependencies (2)
Dev Dependencies (1)
Dependents (1)

Copyright 2014 - 2017 © taobao.org |