开发者社区> 镜像站> NPM> eslint-config-better-standard-react
eslint-config-better-standard-react
A reasonable, extendable ESLint configuration (full config with dependencies) for JSX/React projects
Last updated 3 years ago by blakek .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install eslint-config-better-standard-react 
SYNC missed versions from official npm registry.

eslint-config-better-standard-react

A reasonable, extendable ESLint configuration (full config with dependencies) for JSX/React projects

I really enjoy standard JS style, and I really enjoy their tools. Without the enormous amount of work put into the project, there is no way this one would exist. However, there were things I also didn't particularly enjoy, so this is an attempt at a better version of standard that's like the coding styles actually being used. For the foreseeable future, this will be fewer than 10 tweaks to standard.

The rules are essentially like standard's, but with some of the weird parts changed. For example, this tweaks the parenthesis spacing that always drove me nuts.

The aim of this linting config is to be strict enough to keep you from shooting yourself in the foot while also not putting unnecessary burdens on you when you want to just get stuff done.

Usage

This file is meant to be part of your .eslintrc* file or package.json.

To use this with your package, first install this package, then add the following to your .eslintrc.json file:

{
  "extends": "better-standard-react"
}

or add this in your package.json:

{
  "eslintConfig": {
    "extends": "better-standard-react"
  }
}

You can override settings from this package by writing them in your own .eslintrc. (See ESLint's rules.)

Install

With either Yarn or npm installed, run one of the following:

# If using Yarn:
yarn add eslint-config-better-standard-react

# If using npm:
npm install --save eslint-config-better-standard-react

See Also

License

MIT

Current Tags

  • 0.1.0                                ...           latest (3 years ago)

1 Versions

  • 0.1.0                                ...           3 years ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 0
Last Day 0
Last Week 0
Last Month 0
Dependencies (2)
Dev Dependencies (0)
None
Dependents (0)
None