eslint-config-apiconnect
API Connect core coding conventions
Last updated 4 years ago by kraman .
SEE LICENSE IN LICENSE.txt · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install eslint-config-apiconnect 
SYNC missed versions from official npm registry.

eslint-config-apiconnect

Baseline eslint config for API Connect projects. A work in progress.

Basic Usage

Add eslint-config-apiconnect to devDependencies.

$ npm install -D eslint-config-apiconnect

Create/modify .eslintrc in the project's root to include:

{
  "extends": "apiconnect"
}

Advanced Usage

It is sometimes desirable to override some of these rules because a team does not want to follow that particular rule for this repository:

{
  "extends": "apiconnect",
  "rules": {
    "comma-dangle": 0
  }
}

In cases where these rules are being adopted but the code has many style errors, it might be helpful to turn the worst errors into warnings until the entire repo can be fixed:

{
  "extends": "apiconnect",
  "rules": {
    "comma-dangle": 1,
  }
}

Further Reading


Current Tags

  • 2.0.1                                ...           latest (4 years ago)

2 Versions

  • 2.0.1                                ...           4 years ago
  • 1.0.1                                ...           4 years ago
Downloads
Today 0
This Week 0
This Month 0
Last Day 0
Last Week 0
Last Month 1
Dependencies (0)
None
Dev Dependencies (1)
Dependents (0)
None

Copyright 2014 - 2016 © taobao.org |