electron-meshblu-connector-installer
Cross-Platform Meshblu Connector Installer
Last updated 3 years ago by octoblu .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install electron-meshblu-connector-installer 
SYNC missed versions from official npm registry.

electron-meshblu-connector-installer

Build Status Appveyor Build Status Dependency Status NPM version

Live editing development on desktop app

Electron based Meshblu Connector Installer.

Install

  • Note: requires a node version >= 6 and an npm version >= 3.
  • If you have installation or compilation issues with this project, please see our debugging guide

First, clone the repo via git:

git clone https://github.com/octoblu/electron-meshblu-connector-installer.git

And then install dependencies. ProTip: Install with yarn for faster and safer installation

$ cd electron-meshblu-connector-installer && npm install

Run

Run these two commands simultaneously in different console tabs.

$ npm run hot-server
$ npm run start-hot

or run two servers with one command

$ npm run dev

Editor Configuration

Atom

apm install editorconfig es6-javascript atom-ternjs javascript-snippets linter linter-eslint language-babel autocomplete-modules

Sublime

Others

DevTools

Toggle Chrome DevTools

  • OS X: <kbd>Cmd</kbd> <kbd>Alt</kbd> <kbd>I</kbd> or <kbd>F12</kbd>
  • Linux: <kbd>Ctrl</kbd> <kbd>Shift</kbd> <kbd>I</kbd> or <kbd>F12</kbd>
  • Windows: <kbd>Ctrl</kbd> <kbd>Shift</kbd> <kbd>I</kbd> or <kbd>F12</kbd>

See electron-debug for more information.

DevTools extension

This boilerplate is included following DevTools extensions:

You can find the tabs on Chrome DevTools.

If you want to update extensions version, please set UPGRADE_EXTENSIONS env, just run:

$ UPGRADE_EXTENSIONS=1 npm run dev

# For Windows
$ set UPGRADE_EXTENSIONS=1 && npm run dev

CSS Modules

This boilerplate out of the box is configured to use css-modules.

All .css file extensions will use css-modules unless it has .global.css.

If you need global styles, stylesheets with .global.css will not go through the css-modules loader. e.g. app.global.css

If you want to import global css libraries (like bootstrap), you can just write the following code in .global.css:

@import "~bootstrap/dist/css/bootstrap.css";

Packaging

To package apps for the local platform:

$ npm run package

To package apps for all platforms:

First, refer to Multi Platform Build for dependencies.

Then,

$ npm run package-all

To package apps with options:

$ npm run package -- --[option]

Further commands

To run the application without packaging run

$ npm run build
$ npm start

To run End-to-End Test

$ npm run build
$ npm run test-e2e

Options

See electron-builder CLI Usage

Module Structure

This app uses a two package.json structure.

  1. If the module is native to a platform or otherwise should be included with the published package (i.e. bcrypt, openbci), it should be listed under dependencies in ./app/package.json.
  2. If a module is imported by another module, include it in dependencies in ./package.json. See this ESLint rule.
  3. Otherwise, modules used for building, testing and debugging should be included in devDependencies in ./package.json.

Native-like UI

If you want to have native-like User Interface (OS X El Capitan and Windows 10), react-desktop may perfect suit for you.

License

MIT © C. T. Lin

Current Tags

  • 11.3.7                                ...           latest (3 years ago)

86 Versions

  • 11.3.7                                ...           3 years ago
  • 11.3.6                                ...           3 years ago
  • 11.3.4                                ...           3 years ago
  • 11.3.3                                ...           3 years ago
  • 11.3.2                                ...           3 years ago
  • 11.2.12                                ...           4 years ago
  • 11.2.11                                ...           4 years ago
  • 11.2.10                                ...           4 years ago
  • 11.2.9                                ...           4 years ago
  • 11.2.8                                ...           4 years ago
  • 11.2.7                                ...           4 years ago
  • 11.2.6                                ...           4 years ago
  • 11.2.5                                ...           4 years ago
  • 11.2.4                                ...           4 years ago
  • 11.2.3                                ...           4 years ago
  • 11.2.2                                ...           4 years ago
  • 11.2.1                                ...           4 years ago
  • 11.2.0                                ...           4 years ago
  • 11.1.11                                ...           4 years ago
  • 11.1.10                                ...           4 years ago
  • 11.1.9                                ...           4 years ago
  • 11.1.8                                ...           4 years ago
  • 11.1.7                                ...           4 years ago
  • 11.1.6                                ...           4 years ago
  • 11.1.5                                ...           4 years ago
  • 11.1.4                                ...           4 years ago
  • 11.1.3                                ...           4 years ago
  • 11.1.2                                ...           4 years ago
  • 11.1.1                                ...           4 years ago
  • 11.0.11                                ...           4 years ago
  • 11.0.10                                ...           4 years ago
  • 11.0.9                                ...           4 years ago
  • 11.0.8                                ...           4 years ago
  • 11.0.4                                ...           4 years ago
  • 11.0.3                                ...           4 years ago
  • 11.0.2                                ...           4 years ago
  • 11.0.1                                ...           4 years ago
  • 11.0.0                                ...           4 years ago
  • 10.0.1                                ...           4 years ago
  • 10.0.0                                ...           4 years ago
  • 9.0.3                                ...           4 years ago
  • 9.0.2                                ...           4 years ago
  • 9.0.1                                ...           4 years ago
  • 9.0.0                                ...           4 years ago
  • 8.3.0                                ...           4 years ago
  • 8.2.0                                ...           4 years ago
  • 8.1.1                                ...           4 years ago
  • 8.1.0                                ...           4 years ago
  • 8.0.0                                ...           4 years ago
  • 7.1.0                                ...           4 years ago
  • 7.0.2                                ...           4 years ago
  • 7.0.1                                ...           4 years ago
  • 7.0.0                                ...           4 years ago
  • 6.0.1                                ...           4 years ago
  • 6.0.0                                ...           4 years ago
  • 5.1.3                                ...           4 years ago
  • 5.1.2                                ...           4 years ago
  • 5.1.1                                ...           4 years ago
  • 5.1.0                                ...           4 years ago
  • 5.0.0                                ...           4 years ago
  • 4.0.3                                ...           4 years ago
  • 4.0.2                                ...           4 years ago
  • 4.0.1                                ...           4 years ago
  • 4.0.0                                ...           5 years ago
  • 3.0.3                                ...           5 years ago
  • 3.0.2                                ...           5 years ago
  • 3.0.1                                ...           5 years ago
  • 3.0.0                                ...           5 years ago
  • 2.0.0                                ...           5 years ago
  • 1.1.6                                ...           5 years ago
  • 1.1.5                                ...           5 years ago
  • 1.1.4                                ...           5 years ago
  • 1.1.3                                ...           5 years ago
  • 1.1.2                                ...           5 years ago
  • 1.1.1                                ...           5 years ago
  • 1.0.19                                ...           5 years ago
  • 1.0.18                                ...           5 years ago
  • 1.0.17                                ...           5 years ago
  • 1.0.16                                ...           5 years ago
  • 1.0.14                                ...           5 years ago
  • 1.0.13                                ...           5 years ago
  • 1.0.12                                ...           5 years ago
  • 1.0.10                                ...           5 years ago
  • 1.0.9                                ...           5 years ago
  • 1.0.5                                ...           5 years ago
  • 1.0.2                                ...           5 years ago
Downloads
Today 0
This Week 0
This Month 1
Last Day 0
Last Week 1
Last Month 0
Dependencies (16)
Dependents (0)
None

Copyright 2014 - 2016 © taobao.org |