edge-impulse-cli
Command-line interface tools for Edge Impulse
Last updated 10 days ago by janjongboom1 .
Apache-2.0 · Original npm · Tarball · package.json
$ cnpm install edge-impulse-cli -g
SYNC missed versions from official npm registry.

Edge Impulse CLI tools

Command-line interface tools for Edge Impulse. We make things smarter by enabling developers to create the next generation of intelligent device solutions with embedded Machine Learning.

This package consists of four tools (click to see their respective documentation):

Installation

  1. Install Node.js v10 or higher on your host computer.

  2. Install the CLI tools via:

    $ npm install -g edge-impulse-cli
    

Afterwards you should have the tools available in your PATH.

Troubleshooting

Tools version "2.0" is unrecognized (Windows)

If you receive the following error: The tools version "2.0" is unrecognized. Available tools versions are "4.0", launch a new command window as administrator and run:

$ npm install --global --production windows-build-tools
$ npm config set msvs_version 2015 --global

EACCES: permission denied, access '/usr/local/lib/node_modules' (macOS)

This is indication that the node_modules is not owned by you, but rather by root. This is probably not what you want. To fix this, run:

$ sudo chown -R $USER /usr/local/lib/node_modules

Current Tags

  • 1.8.0                                ...           latest (10 days ago)

34 Versions

  • 1.8.0                                ...           10 days ago
  • 1.7.3                                ...           19 days ago
  • 1.7.2                                ...           25 days ago
  • 1.7.1                                ...           a month ago
  • 1.7.0                                ...           2 months ago
  • 1.6.7                                ...           2 months ago
  • 1.6.6                                ...           2 months ago
  • 1.6.5                                ...           2 months ago
  • 1.6.4                                ...           2 months ago
  • 1.6.3                                ...           2 months ago
  • 1.6.2                                ...           2 months ago
  • 1.6.1                                ...           3 months ago
  • 1.6.0                                ...           3 months ago
  • 1.5.0                                ...           3 months ago
  • 1.4.12                                ...           4 months ago
  • 1.4.11                                ...           4 months ago
  • 1.4.9                                ...           4 months ago
  • 1.4.8                                ...           5 months ago
  • 1.4.7                                ...           6 months ago
  • 1.4.6                                ...           7 months ago
  • 1.4.5                                ...           7 months ago
  • 1.4.4                                ...           7 months ago
  • 1.4.3                                ...           7 months ago
  • 1.4.2                                ...           7 months ago
  • 1.4.0                                ...           7 months ago
  • 1.3.1                                ...           7 months ago
  • 1.3.0                                ...           7 months ago
  • 1.2.2                                ...           8 months ago
  • 1.2.1                                ...           9 months ago
  • 1.2.0                                ...           9 months ago
  • 1.1.3                                ...           10 months ago
  • 1.1.2                                ...           10 months ago
  • 1.1.1                                ...           10 months ago
  • 1.1.0                                ...           10 months ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 2
Last Day 0
Last Week 50
Last Month 77
Dependencies (14)
Dependents (0)
None

Copyright 2014 - 2016 © taobao.org |