dux-statestore-api-client
Dux StateStore API client
Last updated 5 years ago by asbjornenge .
BSD · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install dux-statestore-api-client 
SYNC missed versions from official npm registry.

dux-statestore-api-client

StateStore API client for Dux.

Install

npm install dux-statestore-api-client

Use

var client = require('dux-statestore-api-client')({
    host : 'dux-statestore.dux.test',
    port : 8000
})
client.on('up', client.getState.bind(client, '/containers', function(err, containers) {
    console.log(err, containers)
}))
client.listen()

Changelog

2.0.0

  • De-agrumentified the options

1.0.0

  • Initial release :tada:

enjoy

Current Tags

  • 2.1.0                                ...           latest (5 years ago)

3 Versions

  • 2.1.0                                ...           5 years ago
  • 2.0.0                                ...           5 years ago
  • 1.0.0                                ...           5 years ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 0
Last Day 0
Last Week 0
Last Month 1
Dependencies (3)
Dev Dependencies (0)
None

Copyright 2014 - 2017 © taobao.org |