card-validator-evm
**A biblioteca é utilizada para validar números de Cartões de Crédito**. A atual versão não aceita letras, caracteres especiais, mais ou menos que 16 dígitos.
Last updated a year ago by evilamaior .
ISC · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install card-validator-evm 
SYNC missed versions from official npm registry.

Validador de Cartão de crédito

A biblioteca é utilizada para validar números de Cartões de Crédito. A atual versão não aceita letras, caracteres especiais, mais ou menos que 16 dígitos.

Como instalar

Para instalar, digite o comando a seguir no terminal.

$ npm install card-validator-evm

Como utilizar

Para utilizar a biblioteca, digite o comando a seguir no terminal.

node

const validator = require('card-validator-evm');

console.log(validator.cardValidator('4556155664231703'))

// returns "true"

Roadmap

Versão 2.0.0 (sem previsão, aceita-se contribuições)

  • implementação para gerar números de Cartões de Crédito válidos.
  • implementação para verificar qual a operadora do cartão (Visa, Mastercard, American Express, etc)

Versão 1.0.0

  • funcionalidades: verifica se número do cartão de crédito é válido. Não aceita letras ou caracteres especiais. Não aceita dígitos iguais. Também não aceita cartões com mais ou menos que 16 dígitos.

card-validator

Current Tags

  • 1.0.4                                ...           latest (a year ago)

5 Versions

  • 1.0.4                                ...           a year ago
  • 1.0.3                                ...           a year ago
  • 1.0.2                                ...           a year ago
  • 1.0.1                                ...           a year ago
  • 1.0.0                                ...           a year ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 0
Last Day 0
Last Week 1
Last Month 1
Dependencies (3)
Dev Dependencies (5)
Dependents (0)
None

Copyright 2014 - 2017 © taobao.org |