camunda-modeler-linter-plugin
bpmn-js-bpmnlint as a plug-in for the Camunda Modeler
Last updated 3 months ago by bpmn-io .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install camunda-modeler-linter-plugin 
SYNC missed versions from official npm registry.

camunda-modeler-linter-plugin

Compatible with Camunda Modeler version 3.3

bpmnlint as a plugin for the Camunda Modeler.

Screenshot of the plug-in

Overriding Provided Rules

This plug-ins uses the recommended bpmnlint and Camunda rules.

You may override this via your own Camunda Modeler client plug-in as shown below:

import {
  registerBpmnJSPlugin
} from 'camunda-modeler-plugin-helpers';

import customLinterConfig from './.bpmnlintrc';

registerBpmnJSPlugin({
  __init__: [
    function(linting) {
      linting.setLinterConfig(customLinterConfig);
    }
  ]
});

Please note that you must use the bpmnlint-loader to bundle your .bpmnlintrc for usage in the browser.

For a complete example, checkout the custom-linter-rules-plugin that accomplishes this.

Licence

MIT

Current Tags

  • 0.5.2                                ...           latest (3 months ago)

7 Versions

  • 0.5.2                                ...           3 months ago
  • 0.5.0                                ...           3 months ago
  • 0.4.1                                ...           9 months ago
  • 0.4.0                                ...           9 months ago
  • 0.3.0                                ...           9 months ago
  • 0.2.1                                ...           9 months ago
  • 0.2.0                                ...           9 months ago
Downloads
Today 0
This Week 0
This Month 0
Last Day 0
Last Week 0
Last Month 0
Dependencies (0)
None
Dev Dependencies (10)
Dependents (0)
None

Copyright 2014 - 2016 © taobao.org |