browser-pdf-support
detects support for rendering PDF in browser
Last updated 4 years ago by refractalize .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install browser-pdf-support 
SYNC missed versions from official npm registry.

Can I has PDF?

A tiny NPM module that determines if the browser can render PDFs, either with built-in support like Safari, Chrome and Firefox, or with Adobe Acrobat in Internet Explorer.

The module is expected to be used with the amazing browserify.

var pdfSupport = require('browser-pdf-support');

if (pdfSupport()) {
  console.log('we has PDF!');
} else {
  console.log('oh dear, you'll need to download acrobat or a real browser...');
}

Current Tags

  • 0.2.0                                ...           latest (4 years ago)

3 Versions

  • 0.2.0                                ...           4 years ago
  • 0.1.1                                ...           6 years ago
  • 0.1.0                                ...           6 years ago
Maintainers (1)
Downloads
Today 0
This Week 1
This Month 1
Last Day 1
Last Week 0
Last Month 2
Dependencies (0)
None
Dev Dependencies (1)

Copyright 2014 - 2016 © taobao.org |