babel-preset-latest-node6
Babel preset including es2015-node6, es2016, es2017
Last updated 3 years ago by jhen0409 .
MIT · Original npm · Tarball · package.json
$ cnpm install babel-preset-latest-node6 
SYNC missed versions from official npm registry.

babel-preset-latest-node6

Babel preset including es2015-node6, es2016, es2017.

Install

$ npm install --save-dev babel-preset-latest-node6

Usage

Via .babelrc (Recommended)

.babelrc

{
  "presets": ["latest-node6"]
}

Via CLI

$ babel script.js --presets latest-node6

Via Node API

require("babel-core").transform("code", {
  presets: ["latest-node6"]
});

Options

  • object-rest: Use es2015-node6/object-rest instead of es2015-node6. (See this) (Disabled by default)
  • es2015: Enable es2015-node6 transformations, you can set object to pass es2015 options. (Enabled by default)
  • es2016: Enable es2016 transformations. (Enabled by default)
  • es2017: Enable es2017 transformations. (Enabled by default)
{
  presets: [
    ["latest-node6", {
      "object-rest": true,
      "es2015": { loose: true },
      "es2016": false,
      "es2017": false,
    }]
  ]
}

License

MIT

Current Tags

  • 0.1.1                                ...           latest (3 years ago)

2 Versions

  • 0.1.1                                ...           3 years ago
  • 0.1.0                                ...           4 years ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 1
Last Day 0
Last Week 1
Last Month 1
Dependencies (3)
Dev Dependencies (0)
None

Copyright 2014 - 2017 © taobao.org |