atom-linguist
Language classifier for Atom
Last updated 5 years ago by lee-dohm .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install atom-linguist 
SYNC missed versions from official npm registry.

Atom Linguist

A language classifier for Atom based on GitHub's linguist.

This package is intended to replace the built-in Atom language classification by file extension or first line.

Usage

Linguist = require 'atom-linguist'

Linguist.detect('foo.coffee')     # => 'CoffeeScript'

Copyright

Copyright © 2015 by Lee Dohm and Lifted Studios. See LICENSE for details.

Current Tags

  • 0.1.0                                ...           latest (5 years ago)

1 Versions

  • 0.1.0                                ...           5 years ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 0
Last Day 0
Last Week 0
Last Month 0
Dependencies (3)
Dev Dependencies (9)
Dependents (1)

Copyright 2014 - 2016 © taobao.org |