artillery-engine-http-ntml
Artillery.io engine for NTML support over HTTP/S
Last updated a year ago by hchb_whilke .
MIT · Original npm · Tarball · package.json
$ cnpm install artillery-engine-http-ntml 
SYNC missed versions from official npm registry.

You need to either install this package globably, or npm link it globally so that artillery.io can load the module correctly.

Alternatily, you could symlink this module into the artillery.io local node_modules folder and it will also work.

Once installed, your configuration must be setup in order to use the new engine. You must add the engines property to config, and then set config.http.auth to the correct values. type supports either NTML or Negotiate, setting it to Negotiate will give wider compatibility.

You then need to set the engine for any scenario that should use it, as seen below.

Sample yaml configuration

config:
  engines:
    http-ntml: {}
  http:
    auth:
      username: user
      password: pass
      type: Negotiate
  target: 'http://ntlm.herokuapp.com/'
  phases:
    - duration: 5
      arrivalRate: 1
scenarios:
  - name: "test"
    engine: http-ntml
    flow:
      - get:
          url: "/"

Current Tags

  • 0.1.1                                ...           latest (a year ago)

2 Versions

  • 0.1.1                                ...           a year ago
  • 0.1.0                                ...           a year ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 0
Last Day 0
Last Week 0
Last Month 0
Dependencies (6)
Dev Dependencies (0)
None
Dependents (0)
None

Copyright 2014 - 2016 © taobao.org |