ape-highlighting
ape framework module for highlighting.
Last updated 4 years ago by okunishinishi .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install ape-highlighting 
SYNC missed versions from official npm registry.

ape-highlighting

Build Status Code Climate Code Coverage npm Version JS Standard

ape framework module for highlighting.

Installation

$ npm install ape-highlighting --save

Usage

Highlight JSX source code.

'use strict'

const apeHighlighting = require('ape-highlighting')
const fs = require('fs')

let highlighed = apeHighlighting.highlightJsx(
  fs.readFileSync(require.resolve('../jsx/some-jsx.jsx'))
)

console.log(highlighed)

License

This software is released under the MIT License.

Links

Current Tags

  • 3.1.0                                ...           latest (4 years ago)

6 Versions

  • 3.1.0                                ...           4 years ago
  • 3.0.0                                ...           4 years ago
  • 2.0.1                                ...           5 years ago
  • 2.0.0                                ...           5 years ago
  • 1.1.0                                ...           5 years ago
  • 1.0.0                                ...           5 years ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 0
Last Day 0
Last Week 0
Last Month 12
Dependencies (2)
Dev Dependencies (10)

Copyright 2014 - 2017 © taobao.org |