any-db-postgres
The postgres adapter for any-db
Last updated 3 years ago by grncdr .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install any-db-postgres 
SYNC missed versions from official npm registry.

any-db-postgres

Build Status

js-standard-style

This is the postgres adapter for Any-DB. It relies on the [pg.js][] database driver to create Connection and Query objects that conform to the Any-DB API. The API is practically identical to that of require('pg') but allows your app code to be portable between databases.

API extensions

The connections and queries this package creates inherit from pg.Client and QueryStream, so any methods described there are also available to you.

Keep in mind that these methods will not necessarily work with other backends.

Install

npm install any-db-postgres

License

MIT

Current Tags

  • 2.1.5                                ...           latest (3 years ago)

14 Versions

  • 2.1.5                                ...           3 years ago
  • 2.1.4                                ...           5 years ago
  • 2.1.3                                ...           6 years ago
  • 2.1.2                                ...           6 years ago
  • 2.1.1                                ...           7 years ago
  • 2.1.0                                ...           7 years ago
  • 2.0.0                                ...           7 years ago
  • 1.0.2                                ...           7 years ago
  • 1.0.0                                ...           7 years ago
  • 1.0.0-rc2                                ...           7 years ago
  • 1.0.0-rc1                                ...           7 years ago
  • 1.0.0-alpha2                                ...           7 years ago
  • 1.0.0-alpha1                                ...           7 years ago
  • 0.0.0                                ...           7 years ago

Copyright 2014 - 2016 © taobao.org |