@workast/eslint-config-node
Eslint configs for NodeJS projects
Last updated 2 years ago by orlandovallejos .
Apache-2.0 · Repository · Original npm · Tarball · package.json
$ cnpm install @workast/eslint-config-node 
SYNC missed versions from official npm registry.

Workast Eslint Config for NodeJs

Requirements

  • Node >= 8.0.0
  • Eslint >= 4.9.0

Installation

Install the package as a dev dependency along with its peer dependencies

$ npm install eslint eslint-plugin-import @workast/eslint-config-node --save-dev

Extend it in your .eslintrc.json config file

{
  "extends": "@workast/eslint-config-node"
}

If your project is based on react, then use it like this:

Extend it in your .eslintrc.json config file

{
  "extends": "@workast/eslint-config-node/react"
}

Current Tags

  • 1.1.0                                ...           latest (2 years ago)

3 Versions

  • 1.1.0                                ...           2 years ago
  • 1.0.1                                ...           2 years ago
  • 1.0.0                                ...           2 years ago
Downloads
Today 0
This Week 0
This Month 3
Last Day 0
Last Week 1
Last Month 2
Dependencies (2)
Dev Dependencies (0)
None
Dependents (0)
None

Copyright 2014 - 2016 © taobao.org |