@uppy/server-utils
Client library for communication with Uppy Server. Intended for use in Uppy plugins.
Last updated 3 years ago by goto-bus-stop .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install @uppy/server-utils 
SYNC missed versions from official npm registry.

@uppy/server-utils

Uppy logo: a superman puppy in a pink suit

Build Status

Client library for communication with Uppy Server. Intended for use in Uppy plugins.

Uppy is being developed by the folks at Transloadit, a versatile file encoding service.

Example

const Uppy = require('@uppy/core')
const { Provider, RequestClient, Socket } = require('@uppy/server-utils')

const uppy = Uppy()

const client = new RequestClient(uppy, { serverUrl: 'https://uppy.mywebsite.com/' })
client.get('/drive/list').then(() => {})

const provider = new Provider(uppy, {
  serverUrl: 'https://uppy.mywebsite.com/',
  provider: providerPluginInstance
})
provider.checkAuth().then(() => {})

const socket = new Socket({ target: 'wss://uppy.mywebsite.com/' })
socket.on('progress', () => {})

Installation

Unless you are writing a custom provider plugin, you do not need to install this.

$ npm install @uppy/server-utils --save

License

The MIT License.

Current Tags

  • 0.26.0                                ...           latest (3 years ago)

1 Versions

  • 0.26.0                                ...           3 years ago
Downloads
Today 0
This Week 0
This Month 2
Last Day 0
Last Week 2
Last Month 1
Dependencies (1)
Dev Dependencies (0)
None

Copyright 2014 - 2017 © taobao.org |