@talaikis/node-libs-browser
The node core libs for in browser usage.
Last updated a year ago by talaikis .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install @talaikis/node-libs-browser 
SYNC missed versions from official npm registry.

node-libs-browser

The node core libs for in-browser usage.

NOTE: Thislibrary is a fork of node-libs-browser with updated dependencies, not tested.

dependencies status

Install

npm i @talaikis/node-libs-browser

Exports a hash [object] of absolute paths to each lib, keyed by lib names. Modules without browser replacements are null.

Some modules have mocks in the mock directory. These are replacements with minimal functionality.

lib name browser implementation mock implementation
assert defunctzombie/commonjs-assert ---
buffer feross/buffer buffer.js
child_process --- ---
cluster --- ---
console Raynos/console-browserify console.js
constants juliangruber/constants-browserify ---
crypto crypto-browserify/crypto-browserify ---
dgram --- ---
dns --- dns.js
domain bevry/domain-browser ---
events Gozala/events ---
fs --- ---
http jhiesey/stream-http ---
https substack/https-browserify ---
module --- ---
net --- net.js
os CoderPuppy/os-browserify ---
path substack/path-browserify ---
process shtylman/node-process process.js
punycode bestiejs/punycode.js ---
querystring mike-spainhower/querystring ---
readline --- ---
repl --- ---
stream substack/stream-browserify ---
string_decoder rvagg/string_decoder ---
sys defunctzombie/node-util ---
timers jryans/timers-browserify ---
tls --- tls.js
tty substack/tty-browserify tty.js
url defunctzombie/node-url ---
util defunctzombie/node-util ---
vm substack/vm-browserify ---
zlib devongovett/browserify-zlib ---

Outdated versions

buffer

The current buffer implementation uses feross/buffer@4.x because feross/buffer@5.x relies on typed arrays. This will be dropped as soon as IE9 is not a typical browser target anymore.

punycode

The current punycode implementation uses bestiejs/punycode.js@1.x because bestiejs/punycode.js@2.x requires modern JS engines that understand const and let. It will be removed someday since it has already been deprecated from the node API.

License

MIT

Current Tags

  • 0.0.0                                ...           latest (a year ago)

1 Versions

  • 0.0.0                                ...           a year ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 0
Last Day 0
Last Week 0
Last Month 0
Dependencies (23)
Dependents (0)
None

Copyright 2014 - 2017 © taobao.org |