@salesforce/eslint-plugin-aura
ESLint plugin for Aura
Last updated 10 months ago by maratto .
BSD-3-Clause · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install @salesforce/eslint-plugin-aura 
SYNC missed versions from official npm registry.

eslint-plugin-aura

Build Status NPM version

Salesforce Lightning (Aura) specific linting rules for ESLint

Installation

npm install --global @salesforce/eslint-plugin-aura

Configuration

Add plugin to your ESLint configuration with the recommended config. See ESLint documentation for details.

Example:

{
    "plugins": [ "@salesforce/eslint-plugin-aura" ],
    "extends": [ "plugin:@salesforce/eslint-plugin-aura/recommended" ]
}

Current Tags

  • 1.4.0                                ...           latest (10 months ago)

9 Versions

  • 1.4.0                                ...           10 months ago
  • 1.3.0                                ...           10 months ago
  • 1.2.0                                ...           a year ago
  • 1.0.0                                ...           3 years ago
  • 0.9.4 [deprecated]           ...           3 years ago
  • 0.9.3 [deprecated]           ...           3 years ago
  • 0.9.2 [deprecated]           ...           3 years ago
  • 0.9.1 [deprecated]           ...           3 years ago
  • 0.9.0                                ...           3 years ago

Copyright 2014 - 2017 © taobao.org |