@neoskop/uptrends-api
A NodeJS implementation of the uptrands API
Last updated a year ago by draconisnoctis .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install @neoskop/uptrends-api 
SYNC missed versions from official npm registry.

@neoskop/uptrends-api

An implementation of the Uptrends API for NodeJS (and Browser).

Master Travis master Test coverage master Known Vulnerabilities master

Develop Travis develop Test coverage develop Known Vulnerabilities develop

Installation

yarn add @neoskop/uptrends-api

Usage

import { UptrendsAPI } from '@neoskop/uptrends-api'

const api = new UptrendsAPI({ username: 'foo', password: 'bar' });

api.getProbeGroups().then(groups => {
    console.log(groups);
}, err => {
    console.err(err);
});

Testing

yarn test

Building

yarn run build

License

MIT

Sponsor

Neoskop GmbH

Current Tags

  • 2.0.1                                ...           latest (a year ago)

7 Versions

  • 2.0.1                                ...           a year ago
  • 2.0.1-rc.1                                ...           a year ago
  • 2.0.0                                ...           2 years ago
  • 2.0.0-rc.3                                ...           2 years ago
  • 2.0.0-rc.0                                ...           2 years ago
  • 1.0.1                                ...           3 years ago
  • 1.0.0                                ...           3 years ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 0
Last Day 0
Last Week 0
Last Month 0
Dependencies (2)
Dev Dependencies (22)
Dependents (0)
None

Copyright 2014 - 2016 © taobao.org |