@movinliao/eslint-config-mlc
ESLint 配置标准。
Last updated 2 years ago by movinliao .
UNLICENSED · Repository · Original npm · Tarball · package.json
$ cnpm install @movinliao/eslint-config-mlc 
SYNC missed versions from official npm registry.

ESLint 配置标准

给 [mlc]项目使用。其他项目也可以使用。

主要风格

配置使用

在项目的 package.json 文件中配置。

{
  "eslintConfig": {
    "extends": "@movinliao/mlc"
  },
  "eslintIgnore": [
    "/dev",
    "/output"
  ],
}

可选配置:

  • 标准(新的 MLC 项目):@movinliao/mlc
  • 旧的 MLC ES5 项目(为了兼容旧项目,新项目请忽略):@movinliao/mlc/airbnb-es5
  • 旧的 MLC ES6 项目(为了兼容旧项目,新项目请忽略):@movinliao/mlc/airbnb

结合编辑器使用

安装全局环境依赖。

npm i -g eslint @movinliao/eslint-config-mlc eslint-plugin-import eslint-plugin-node eslint-plugin-promise eslint-config-standard eslint-plugin-standard eslint-plugin-vue babel-eslint

VS Code

安装扩展。

配置。

{
  "eslint.validate": [
    "javascript",
    "javascriptreact",
    { "language": "vue", "autoFix": true },
    { "language": "html", "autoFix": true }
  ]
}

Current Tags

  • 0.0.4                                ...           latest (2 years ago)

4 Versions

  • 0.0.4                                ...           2 years ago
  • 0.0.3                                ...           2 years ago
  • 0.0.2                                ...           2 years ago
  • 0.0.1                                ...           2 years ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 2
Last Day 0
Last Week 2
Last Month 3
Dev Dependencies (0)
None

Copyright 2014 - 2017 © taobao.org |