@mocoding/eslint-config
Shared eslint and prettier configuration
Last updated 15 days ago by mocoding.npm.admin .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install @mocoding/eslint-config 
SYNC missed versions from official npm registry.

@mocoding/eslint-config

Shared eslint and prettier configuration

This package is a part of @mocoding/react-app library. It contains shared eslint and prettier settings configured to work together for Typescript and React.

Getting started

Install package as development dependency:

yarn add --dev @mocoding/eslint-config

Add the following to lines to package.json file:

  "eslintConfig": {
    "extends": "@mocoding/eslint-config"
  },
  "prettier": "@mocoding/eslint-config/prettier"

Details

Several important notes:

  1. Width is set to 90 as I found it anough to fit into 27' monitor with split screen, files browser and map. It works for me. It may work for you but it will not work for everybody. Example
  2. react/prop-types is disabled. It does not required for Typescript
  3. @typescript-eslint/explicit-function-return-type changed to warn and allowExpressions is set to true.

Current Tags

  • 1.0.1                                ...           latest (15 days ago)

3 Versions

  • 1.0.1                                ...           15 days ago
  • 1.0.0                                ...           23 days ago
  • 1.0.0-rc                                ...           23 days ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 32
Last Day 0
Last Week 0
Last Month 0
Dev Dependencies (0)
None
Dependents (1)

Copyright 2014 - 2016 © taobao.org |