@lunit/eslint-config
Lunit eslint config
Last updated 2 months ago by ssen .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install @lunit/eslint-config 
SYNC missed versions from official npm registry.

ESLint config

Basic Usage

Install dependencies.

npm install eslint @lunit/eslint-config eslint-config-prettier --save-dev

Add this config into package.json if the project is a React application.

{
  "eslintConfig": {
    "extends": [
      "@lunit",
      "prettier",
      "prettier/react",
      "prettier/@typescript-eslint"
    ]
  }
}

Or add this config into package.json if the project is not a React application. (like a Node.js application)

{
  "eslintConfig": {
    "extends": [
      "@lunit/eslint-config/without-react",
      "prettier",
      "prettier/@typescript-eslint"
    ]
  }
}

Current Tags

  • 0.4.0-alpha.1                                ...           alpha (3 months ago)
  • 0.5.0                                ...           latest (2 months ago)

6 Versions

  • 0.5.0                                ...           2 months ago
  • 0.4.0                                ...           3 months ago
  • 0.4.0-alpha.1                                ...           3 months ago
  • 0.3.0                                ...           3 months ago
  • 0.2.4                                ...           3 months ago
  • 0.1.0                                ...           3 months ago
Downloads
Today 0
This Week 0
This Month 1
Last Day 0
Last Week 0
Last Month 0
Dev Dependencies (0)
None
Dependents (0)
None

Copyright 2014 - 2016 © taobao.org |