@lodgify/eslint-config
ESLint config for Lodgify's projects.
Last updated a year ago by lodgify-ci .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install @lodgify/eslint-config 
SYNC missed versions from official npm registry.

Lodgify's ESLint config ????

Set of ESLint rules and plugins used accross Lodgify's projects.

Installation

Add @lodgify/eslint-config to your dev dependencies.

npm install --save-dev @lodgify/eslint-config
yarn add --dev @lodgify/eslint-config

Use it in your .eslintrc file.

{
  "extends": ["@lodgify"]
}

Prettier

If you use the Prettier CLI directly, or if you need to integrate it with some fancy text editor, you might need to add a Prettier config file to your root directory.

You can use this prettier.config.js file for that.

module.exports = require('@lodgify/eslint-config/prettier.config.js');

Current Tags

  • 3.0.0                                ...           latest (a year ago)

6 Versions

  • 3.0.0                                ...           a year ago
  • 2.2.1                                ...           a year ago
  • 2.2.0                                ...           2 years ago
  • 2.1.0                                ...           2 years ago
  • 2.0.1                                ...           2 years ago
  • 2.0.0                                ...           2 years ago
Maintainers (1)
Downloads
Today 0
This Week 6
This Month 14
Last Day 0
Last Week 0
Last Month 0
Dev Dependencies (6)
Dependents (0)
None

Copyright 2014 - 2016 © taobao.org |