@ionic/swiftlint-config
SwiftLint config for Ionic and Capacitor
Last updated 2 months ago by dwieeb .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install @ionic/swiftlint-config 
SYNC missed versions from official npm registry.

@ionic/swiftlint-config

Shared SwiftLint config used in Ionic and Capacitor projects. This must be used with the swiftlint wrapper for npm projects.

Usage

  1. Install the swiftlint wrapper by following these instructions.

  2. Remove existing .swiftlint.yml file, if present.

  3. Install the config in your project.

    npm install -D @ionic/swiftlint-config
    
  4. Configure the swiftlint wrapper by adding a swiftlint key at the root of your project's package.json.

    "swiftlint": "@ionic/swiftlint-config",
    

    Alternatively, to override options, you can create a swiftlint.config.js file:

    module.exports = {
      ...require('@ionic/swiftlint-config'),
    
      // override options here
    };
    

    It might be worth creating a PR to this config repo first, though! We'd love to discuss changes. :blue_heart:

Current Tags

  • 1.1.2                                ...           latest (2 months ago)

8 Versions

  • 1.1.2                                ...           2 months ago
  • 1.1.1                                ...           3 months ago
  • 1.1.0                                ...           3 months ago
  • 1.0.2                                ...           3 months ago
  • 1.0.1                                ...           3 months ago
  • 1.0.0                                ...           3 months ago
  • 0.0.2                                ...           3 months ago
  • 0.0.1                                ...           3 months ago

Copyright 2014 - 2017 © taobao.org |