@inrupt/solid-client-authn-node
`solid-client-authn-node` is a library designed to authenticate Node.js apps (both scripts and full-blown Web servers) with Solid identity servers. The main documentation is at the [root of the repository](https://github.com/inrupt/solid-client-authn-js).
Last updated 7 days ago by inrupt_ci .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install @inrupt/solid-client-authn-node 
SYNC missed versions from official npm registry.

Solid JavaScript authentication for Node.js - solid-client-authn-node

solid-client-authn-node is a library designed to authenticate Node.js apps (both scripts and full-blown Web servers) with Solid identity servers. The main documentation is at the root of the repository.

Underlying libraries

solid-client-authn-node is based on jose.

Other Inrupt Solid JavaScript Libraries

@inrupt/solid-client-authn-nodeis part of a family open source JavaScript libraries designed to support developers building Solid applications.

Inrupt Solid JavaScript Client Libraries

Data access and permissions management - solid-client

@inrupt/solid-client allows developers to access data and manage permissions on data stored in Solid Pods.

Authentication - solid-client-authn

@inrupt/solid-client-authn allows developers to authenticate against a Solid server. This is necessary when the resources on your Pod are not public.

Vocabularies and interoperability - solid-common-vocab-rdf

@inrupt/solid-common-vocab-rdf allows developers to build interoperable apps by reusing well-known vocabularies. These libraries provide vocabulary terms as constants that you just have to import.

Issues & Help

Solid Community Forum

If you have questions about working with Solid or just want to share what you’re working on, visit the Solid forum. The Solid forum is a good place to meet the rest of the community.

Bugs and Feature Requests

  • For public feedback, bug reports, and feature requests please file an issue via GitHub.
  • For non-public feedback or support inquiries please use the Inrupt Service Desk.

Prerequisite

This library requires at least:

  • NodeJS 12.X.Y
  • npm 6.14.X Note: We recommend using nvm to manage your node version.

The solid-client-authn libraries are compatible with NSS 5.3.X and higher.

Documentation

Current Tags

1568 Versions

Downloads
Today 34,392
This Week 322,025
This Month 23,497,344
Last Day 98,437
Last Week 19,865,384
Last Month 1,894,318
Dependencies (9)
Dev Dependencies (8)

Copyright 2014 - 2016 © taobao.org |