@i-views/bower-resolver

bower-resolver for downloading software by i-views

Use of this package is deprecated
Last updated a year ago by knappi .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install @i-views/bower-resolver 
SYNC missed versions from official npm registry.

@i-views/bower-resolver

NPM version

bower-resolver for downloading software by i-views

About i-views

intelligent views gmbh (i-views) is one of the leading providers of semantic technologies and applications in the German-speaking region. The company, which started out in 1997 as a spin-off of the Fraunhofer Society, has over 30 employees and is based in Darmstadt, Germany. The company produces the i-views Smart Data Engine, which provides customers with an easy and flexible way of creating smart data networks, thus increasing the value of their data.

If you want to know more about i-views, please have a look at the following web-sites:

Purpose

Deprecation notice: The bower-resolver is deprecated. We have moved away from bower, so this package will not be updated anymore. The source for downloading the package will also not receive updates anymore. Please contact us, if you need current versions of our software.

In addition the our core-product, we provide a web-frontend called the viewconfigmapper that can be used and configured with our backend. The @i-views/bower-resolver helps you download and use this frontend in your own projects.

Please note that while the @i-views/bower-resolver is released under the MIT-License, most of the packages it downloads are under a propriatery license.

Installation

npm install --save-dev @i-views/bower-resolver

Make sure that the following files in your project are similar to what is shown here:

.bowerrc

Include @i-views/bower-resolver in your.bowerrc file to tell Bower that it should use this resolver for the dependencies defined in bower.json:

{
  "resolvers": [
    "@i-views/bower-resolver"
  ]
}

bower.json

Add a reference to an i-views dependency in your bower.json. The version is specified by the reference part, e.g. #5.0.4. If no version is given then the latest version will be automatically downloaded by Bower.

{
  "name": "example-project",
  "dependencies": {
    "viewconfigmapper": "iviews://viewconfigmapper#5.0.4"
  },
  "license": "MIT"
}

When you run

bower install

the resolver will download the viewconfigmapper from the i-views download servers.

License

@i-views/bower-resolver is published under the MIT-license.

See LICENSE.md for details.

Release-Notes

For release notes, see CHANGELOG.md

Contributing guidelines

See CONTRIBUTING.md.

Current Tags

  • 1.0.4                                ...           latest (a year ago)

5 Versions

  • 1.0.4 [deprecated]           ...           a year ago
  • 1.0.3 [deprecated]           ...           3 years ago
  • 1.0.2 [deprecated]           ...           3 years ago
  • 1.0.1 [deprecated]           ...           3 years ago
  • 1.0.0 [deprecated]           ...           3 years ago
Maintainers (3)
Downloads
Today 0
This Week 0
This Month 0
Last Day 0
Last Week 5
Last Month 6
Dependencies (6)
Dev Dependencies (19)
Dependents (0)
None

Copyright 2014 - 2016 © taobao.org |