@heroku/marketing-tailwind-config
The Tailwind config for Heroku marketing
Last updated 4 months ago by superhighfives .
UNLICENSED · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install @heroku/marketing-tailwind-config 
SYNC missed versions from official npm registry.

marketing-tailwind-config

The custom Tailwind config for the marketing properties on Heroku.

All classes are prefixed with tw- to avoid clashing with existing classes.

This configuration covers:

  • colours
  • gradients
  • fonts and typography
  • transitions
  • lobotomized owl selectors for margin-top via the .tw-owl-mt- classes
  • min-height via the .tw-min-h- classes

You can use the configuration in your PostCSS configuration. For example, in a standard Rails postcss.config.js file:

module.exports = {
  plugins: [
    require('postcss-import'),
    require('autoprefixer'),
    require('postcss-flexbugs-fixes'),
    require('tailwindcss')('node_modules/@heroku/marketing-tailwind-config'),
    require('postcss-preset-env')({
      autoprefixer: {
        flexbox: 'no-2009',
      },
      stage: 3,
    }),
  ],
}

Current Tags

  • 1.0.3                                ...           latest (4 months ago)

4 Versions

  • 1.0.3                                ...           4 months ago
  • 1.0.2                                ...           5 months ago
  • 1.0.1                                ...           8 months ago
  • 1.0.0                                ...           8 months ago
Maintainers (261)
Downloads
Today 0
This Week 0
This Month 0
Last Day 0
Last Week 0
Last Month 0
Dependencies (0)
None
Dev Dependencies (0)
None
Dependents (0)
None

Copyright 2014 - 2017 © taobao.org |