@fooxly/babel-preset-react
The default Babel preset for Fooxly projects using React.
Last updated 7 months ago by luchermkens .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install @fooxly/babel-preset-react 
SYNC missed versions from official npm registry.

Fooxly Babel Preset for React

The default Babel preset for Fooxly projects using React.

npm version downloads ci status

:rocket:  Powered By

:heart:  Support us

About 40% of your donation goes to one of the charities we support. For further information or questions please visit our website or contact us via charity@fooxly.com.

BuyMeACoffee    Patreon    PayPal


:cloud:  Installation

using npm

npm install --save-dev @fooxly/babel-preset-react

using yarn

yarn add -D @fooxly/babel-preset-react

:triangular_ruler:  Usage

using .babelrc

{
  "presets": ["@fooxly/babel-preset-react"]
}

using package.json

...
"babel": {
  "presets": ["@fooxly/babel-preset-react"]
}
...

using React Native

Make sure to check out the README of the Metro Babel preset in order to use the latest available React Native technologies.

You must include the noEnv: true option and require this preset after the Metro one, in order for this preset to work with React Native.

{
  "presets": [
    "module:metro-react-native-babel-preset",
    ["@fooxly/babel-preset-react", { "noEnv": true }]
  ]
}

Current Tags

  • 3.0.0                                ...           latest (7 months ago)

5 Versions

  • 3.0.0                                ...           7 months ago
  • 2.1.0                                ...           8 months ago
  • 2.0.0                                ...           8 months ago
  • 1.0.1                                ...           8 months ago
  • 1.0.0                                ...           8 months ago
Maintainers (2)
Downloads
Today 0
This Week 0
This Month 0
Last Day 0
Last Week 0
Last Month 0
Dev Dependencies (1)
Dependents (0)
None

Copyright 2014 - 2016 © taobao.org |