@dicy/core
Library interface to DiCy, a builder for LaTeX, knitr, literate Agda, literate Haskell and Pweave that automatically builds dependencies.
Last updated a year ago by yitzchak .
MIT · Repository · Original npm · Tarball · package.json
$ cnpm install @dicy/core 
SYNC missed versions from official npm registry.

@dicy/core

Build Status Windows Build Status Dependency Status devDependency Status

This package is a library interface to DiCy, a JavaScript/TypeScript based builder for LaTeX, knitr, Literate Agda, Literate Haskell, and Pweave that automatically builds dependencies. DiCy parses and filters output logs and error messages generated during build and can build projects that utilize the following programs to process files.

  • Bibliographies — Biber, BibTeX, BibTeX8, BibTeXu, pBibTeX, upBibTeX
  • Graphics Creation — Asymptote, MetaPost
  • Image/File Conversion — dvipdfm, dvipdfmx, dvips, dvisvgm, epstopdf, pdf2ps, ps2pdf
  • Indexing/Glossaries — bib2gls, makeglossaries, makeindex, mendex, splitindex, texindy, upmendex
  • LaTeX Engines — LaTeX, LuaLaTeX, pdfLaTeX, pLaTeX, upLaTeX, XeLaTeX
  • Literate Programming/Reproducible Research — Agda, knitr, lhs2TeX, patchSynctex, PythonTeX, Pweave, SageTeX

More information, including installation and API documentation is available at the DiCy website.

License

This project is licensed under the MIT License - see the LICENSE.md file for details.

Current Tags

  • 0.15.2                                ...           latest (a year ago)

29 Versions

  • 0.15.2                                ...           a year ago
  • 0.15.1                                ...           2 years ago
  • 0.15.0                                ...           2 years ago
  • 0.14.1                                ...           2 years ago
  • 0.14.0                                ...           2 years ago
  • 0.13.0                                ...           2 years ago
  • 0.12.3                                ...           2 years ago
  • 0.12.2                                ...           3 years ago
  • 0.12.1                                ...           3 years ago
  • 0.12.0                                ...           3 years ago
  • 0.12.0-pre.0                                ...           3 years ago
  • 0.11.0                                ...           3 years ago
  • 0.10.1                                ...           3 years ago
  • 0.10.0                                ...           3 years ago
  • 0.9.1                                ...           3 years ago
  • 0.9.0                                ...           3 years ago
  • 0.8.0                                ...           3 years ago
  • 0.7.0                                ...           3 years ago
  • 0.6.0                                ...           3 years ago
  • 0.5.0                                ...           3 years ago
  • 0.4.1                                ...           3 years ago
  • 0.4.0                                ...           3 years ago
  • 0.3.2                                ...           3 years ago
  • 0.3.1                                ...           3 years ago
  • 0.3.0                                ...           3 years ago
  • 0.2.2                                ...           3 years ago
  • 0.2.1                                ...           3 years ago
  • 0.2.0                                ...           3 years ago
  • 0.1.0                                ...           3 years ago
Maintainers (1)
Downloads
Today 1
This Week 1
This Month 1
Last Day 0
Last Week 1
Last Month 40
Dependencies (15)
Dev Dependencies (17)
Dependents (2)

Copyright 2014 - 2016 © taobao.org |