• 关于

    xampp默认网站目录

    的搜索结果

问题

在xampp套件中的apache2.4启用Webdav功能

在xampp套件中的apache2.4启用Webdav功能 一用户问,为什么在旧版的xampp里可以很方便使用xampp中的webdav功能来建NAS网络存储,但新版本不行。 经过测试和网上的搜索结果&#...
dongshan8 2019-12-01 21:07:24 7597 浏览量 回答数 3

问题

在linux下配置php开发环境403.10 禁止访问:配置无效

在linux下配置php开发环境是直接安装lamp好一些,还是一个一个安装好一些啊? 如果是非编译安装都差不多,不过直接安装lamp server套件就相当于一键安装了,省事。###...
kun坤 2020-05-27 14:01:49 3 浏览量 回答数 1

回答

如果是非编译安装都差不多,不过直接安装lamp server套件就相当于一键安装了,省事。######CentOS 可以通过 yum 安装: yum -y install httpd php php-mysql  mysql-server service httpd status|start|stop|restart|reload service mysqld status|start|stop|restart|reload 网站根目录 /var/www/html/ Apache主目录 /etc/httpd/ Apache主配置文件 /etc/httpd/conf/httpd.conf Apache日志 /etc/httpd/logs/ PHP主目录 /etc/php.d/ PHP配置文件 /etc/php.ini PHP模块位置 /usr/lib/php/ 或者 /usr/lib64/php/ MySQL配置文件 /etc/my.cnf MySQL数据库文件 /var/lib/mysql/ 运行 mysql_secure_installation 设置mysql根用户密码 Ubuntu可以这样安装: sudo apt-get -y install apache2 php5 php5-mysql mysql-server mysql-client sudo service apache2 status|start|stop|restart|reload sudo service mysql status|start|stop|restart|reload 网站根目录 /var/www Apache主目录 /etc/apache2/ Apache主配置文件 /etc/apache2/apache2.conf Apache日志 /var/log/apache2/ PHP主目录 /etc/php5/ PHP配置文件 /etc/php5/apache2/php.ini PHP模块位置 /usr/lib/php5/ MySQL配置文件 /etc/mysql/my.cnf MySQL数据库文件 /var/lib/mysql/ 运行 mysql_secure_installation 设置mysql根用户密码 ###### http://www.oschina.net/code/snippet_105637_19620######xampp,一秒钟搞定所有###### 哈,ubuntu系统好方便的: 在终端输入: sudo apt-get install apache2 php5 libapache2-mod-php5 mysql-server libapache2-mod-auth-mysql php5-mysql 全部搞定。 Apache默认DocumentRoot在/var/www下 也可以看看这个配置方法######现成的lamp或者lnmp或者lanmp都是用脚本自动编译安装的,如果你是为了学习编译安装,可以看下这些脚本,然后自己尝试一个个编译安装。如果你是为了配置生产环境,并且你也没有什么特别的需求(比如要自定义模块,自定义安装路径之类的),那可以直接用lamp一类的自动搭建就好了,或者也可以直接yum/apt-get来安装也行(速度相对较快)。 ######谢谢,我是初学linux,所以是一个个编译安装的!###### 用apt或yum装有个问题,就是版本不可控,比如你用ubuntu最新版,给你装上的就是5.4,你想用5.3就没辙了 zend公司提供了一个开发套装,zend server,可以挂上他们的第三方软件源用apt安装,php版本可选。这个方案也有麻烦的地方,就是一些第三方库他跟你集成了,有的框架识别不出来,很操蛋。 最靠谱的当然是编译安装,但是初学者如果按照网上的一些博客搞,也不是个事,因为那些文章往往很老了,不一定符合实际。且想卸载只能手动搞。所以还是用个一键编译脚本比较好,一般都带了卸载脚本。 lnmp.org不错,但是最新版太自动了,二话不说毫无提示的直接把我的KDE桌面给干掉了。不知是哪个包有冲突。但是我自己把KDE再装上也没发现有啥冲突发生。。。。 ######其实看着那些自动安装脚本来学习编译是件灰常潮流的事情,比博客与时俱进得多。######应该是python冲突了######推荐用源码编译,另外可以尝试nginx代替apache######不是治理做系统管理员就用套件"
一枚小鲜肉帅哥 2020-05-28 10:03:44 0 浏览量 回答数 0

回答

如果是非编译安装都差不多,不过直接安装lamp server套件就相当于一键安装了,省事。######CentOS 可以通过 yum 安装: yum -y install httpd php php-mysql  mysql-server service httpd status|start|stop|restart|reload service mysqld status|start|stop|restart|reload 网站根目录 /var/www/html/ Apache主目录 /etc/httpd/ Apache主配置文件 /etc/httpd/conf/httpd.conf Apache日志 /etc/httpd/logs/ PHP主目录 /etc/php.d/ PHP配置文件 /etc/php.ini PHP模块位置 /usr/lib/php/ 或者 /usr/lib64/php/ MySQL配置文件 /etc/my.cnf MySQL数据库文件 /var/lib/mysql/ 运行 mysql_secure_installation 设置mysql根用户密码 Ubuntu可以这样安装: sudo apt-get -y install apache2 php5 php5-mysql mysql-server mysql-client sudo service apache2 status|start|stop|restart|reload sudo service mysql status|start|stop|restart|reload 网站根目录 /var/www Apache主目录 /etc/apache2/ Apache主配置文件 /etc/apache2/apache2.conf Apache日志 /var/log/apache2/ PHP主目录 /etc/php5/ PHP配置文件 /etc/php5/apache2/php.ini PHP模块位置 /usr/lib/php5/ MySQL配置文件 /etc/mysql/my.cnf MySQL数据库文件 /var/lib/mysql/ 运行 mysql_secure_installation 设置mysql根用户密码 ###### http://www.oschina.net/code/snippet_105637_19620######xampp,一秒钟搞定所有###### 哈,ubuntu系统好方便的: 在终端输入: sudo apt-get install apache2 php5 libapache2-mod-php5 mysql-server libapache2-mod-auth-mysql php5-mysql 全部搞定。 Apache默认DocumentRoot在/var/www下 ######谢谢,呵呵!###### http://my.oschina.net/pqiankui/blog/144241也可以看看这个配置方法######现成的lamp或者lnmp或者lanmp都是用脚本自动编译安装的,如果你是为了学习编译安装,可以看下这些脚本,然后自己尝试一个个编译安装。如果你是为了配置生产环境,并且你也没有什么特别的需求(比如要自定义模块,自定义安装路径之类的),那可以直接用lamp一类的自动搭建就好了,或者也可以直接yum/apt-get来安装也行(速度相对较快)。 ######谢谢,我是初学linux,所以是一个个编译安装的!###### 用apt或yum装有个问题,就是版本不可控,比如你用ubuntu最新版,给你装上的就是5.4,你想用5.3就没辙了 zend公司提供了一个开发套装,zend server,可以挂上他们的第三方软件源用apt安装,php版本可选。这个方案也有麻烦的地方,就是一些第三方库他跟你集成了,有的框架识别不出来,很操蛋。 最靠谱的当然是编译安装,但是初学者如果按照网上的一些博客搞,也不是个事,因为那些文章往往很老了,不一定符合实际。且想卸载只能手动搞。所以还是用个一键编译脚本比较好,一般都带了卸载脚本。 lnmp.org不错,但是最新版太自动了,二话不说毫无提示的直接把我的KDE桌面给干掉了。不知是哪个包有冲突。但是我自己把KDE再装上也没发现有啥冲突发生。。。。 ######其实看着那些自动安装脚本来学习编译是件灰常潮流的事情,比博客与时俱进得多。######应该是python冲突了######推荐用源码编译,另外可以尝试nginx代替apache######不是治理做系统管理员就用套件
montos 2020-05-30 23:37:58 0 浏览量 回答数 0

回答

如果是非编译安装都差不多,不过直接安装lamp server套件就相当于一键安装了,省事。######CentOS 可以通过 yum 安装: yum -y install httpd php php-mysql  mysql-server service httpd status|start|stop|restart|reload service mysqld status|start|stop|restart|reload 网站根目录 /var/www/html/ Apache主目录 /etc/httpd/ Apache主配置文件 /etc/httpd/conf/httpd.conf Apache日志 /etc/httpd/logs/ PHP主目录 /etc/php.d/ PHP配置文件 /etc/php.ini PHP模块位置 /usr/lib/php/ 或者 /usr/lib64/php/ MySQL配置文件 /etc/my.cnf MySQL数据库文件 /var/lib/mysql/ 运行 mysql_secure_installation 设置mysql根用户密码 Ubuntu可以这样安装: sudo apt-get -y install apache2 php5 php5-mysql mysql-server mysql-client sudo service apache2 status|start|stop|restart|reload sudo service mysql status|start|stop|restart|reload 网站根目录 /var/www Apache主目录 /etc/apache2/ Apache主配置文件 /etc/apache2/apache2.conf Apache日志 /var/log/apache2/ PHP主目录 /etc/php5/ PHP配置文件 /etc/php5/apache2/php.ini PHP模块位置 /usr/lib/php5/ MySQL配置文件 /etc/mysql/my.cnf MySQL数据库文件 /var/lib/mysql/ 运行 mysql_secure_installation 设置mysql根用户密码 ###### http://www.oschina.net/code/snippet_105637_19620######xampp,一秒钟搞定所有###### 哈,ubuntu系统好方便的: 在终端输入: sudo apt-get install apache2 php5 libapache2-mod-php5 mysql-server libapache2-mod-auth-mysql php5-mysql 全部搞定。 Apache默认DocumentRoot在/var/www下 ######谢谢,呵呵!###### http://my.oschina.net/pqiankui/blog/144241也可以看看这个配置方法######现成的lamp或者lnmp或者lanmp都是用脚本自动编译安装的,如果你是为了学习编译安装,可以看下这些脚本,然后自己尝试一个个编译安装。如果你是为了配置生产环境,并且你也没有什么特别的需求(比如要自定义模块,自定义安装路径之类的),那可以直接用lamp一类的自动搭建就好了,或者也可以直接yum/apt-get来安装也行(速度相对较快)。 ######谢谢,我是初学linux,所以是一个个编译安装的!###### 用apt或yum装有个问题,就是版本不可控,比如你用ubuntu最新版,给你装上的就是5.4,你想用5.3就没辙了 zend公司提供了一个开发套装,zend server,可以挂上他们的第三方软件源用apt安装,php版本可选。这个方案也有麻烦的地方,就是一些第三方库他跟你集成了,有的框架识别不出来,很操蛋。 最靠谱的当然是编译安装,但是初学者如果按照网上的一些博客搞,也不是个事,因为那些文章往往很老了,不一定符合实际。且想卸载只能手动搞。所以还是用个一键编译脚本比较好,一般都带了卸载脚本。 lnmp.org不错,但是最新版太自动了,二话不说毫无提示的直接把我的KDE桌面给干掉了。不知是哪个包有冲突。但是我自己把KDE再装上也没发现有啥冲突发生。。。。 ######其实看着那些自动安装脚本来学习编译是件灰常潮流的事情,比博客与时俱进得多。######应该是python冲突了######推荐用源码编译,另外可以尝试nginx代替apache######不是治理做系统管理员就用套件
kun坤 2020-06-06 18:54:05 0 浏览量 回答数 0

回答

编译 在你原来的编译参数中加入:--enable-http2 ,这里解释一下编译参数:(请原谅我的英语不好) --enable-http2 让 Apache Httpd 可以实现 HTTP/2 协议 --with-nghttp2=<dir> 自定义你 libnghttp2 的安装目录 Windows 目前 XAMPP 的最新安装包默认就是 2.4.17 ,且有 http2 mod。 upupw 暂时还没有。 设置 软件源 通过软件源安装的用户,需要在 /etc/apache2/mods-enabled 或者 /etc/httpd/mod-enabled 中创建一个 http2.load ,里面加入LoadModule http2_module /usr/lib/apache2/modules/mod_http2.so 然后保存,重启 服务。 编译/windows 在 httpd.conf 中,找到#LoadModule http2_module /usr/lib/apache2/modules/mod_http2.so 将前面的 # 取消,如果没有这句话,就直接添加去掉 # 后的语句。 然后保存,重启服务。 开启 h2 编辑对应的 vhost 文件,找到 443 端口的地方,加入: <VirtualHost x.x.x.x:443 >ProtocolsHonorOrder OnProtocols h2 h2c http/1.1………………</VirtualHost> 其实 80 端口也可以加入 Protocols h2c http/1.1 ,但是暂时没有浏览器加入对 80 端口的 http/2 支持。 还是那句话,不要忘记重启。 查看 chrome 浏览器可以在 chrome://net-internals/#http2 中查看,使用 http/2 的网站,看看有没有你添加的。 也可以通过 curl 来查看:curl -v --http2 http://<yourserver>/ ------------------------- 回 2楼(梦丫头) 的帖子 多谢梦姑赏识~~ ------------------------- 回 4楼(小柒2012) 的帖子 虽然怎么用  apche ?
妙正灰 2019-12-01 23:56:34 0 浏览量 回答数 0

回答

没人理我吗? ###### 看这个 http://code.google.com/p/modwsgi/wiki/QuickConfigurationGuide ######你能说下吗?###### 以下只是我的Wsgi部分的配置(httpd.conf): LoadModule wsgi_module modules/mod_wsgi.so WSGIScriptAlias /wsgi /django-app/SimpleCRM/SimpleCRM/wsgi.py WSGIPythonPath /django-app/SimpleCRM AddType text/html .py <Directory /django-app/SimpleCRM/SimpleCRM>      AllowOverride All      Options ExecCGI      Order deny,allow      Allow from All </Directory> 我用的是XAMPP。 ######回复 @dreamhack : 你在Command Prompt下非Python目录里可以跑Python的Code 吗?######嗯,谢谢,我的还是不行,除了这段配置不需要设置别的了?python解释器怎么办?我弄好几天了,实在解决不了!你安装django了,我只是搭建环境,没框架,能跑py web就行!###### 在System Property->Environment Variables的Sytem variables 或者User variables 中选择Path,选Edit,加上你的路径。 ###### 设置环境变量,XP看看这个:http://best-windows.vlaurie.com/environment-variables.html 和这个:http://www.computerhope.com/issues/ch000549.htm Win 7, 看这个:http://geekswithblogs.net/renso/archive/2009/10/21/how-to-set-the-windows-path-in-windows-7.aspx ######回复 @dreamhack : 是py的路径。######嗯,啥路径?python安装的路径?还是网站工作的路径呢?######安装两个版本没有问题,在路径中选一个就是了。######回复 @dreamhack : 关键是每一个人的机器的环境并不相同,你不可能完全按照别人写的做。你要能够理解每一步本身的含义才好。######很不好意思告诉您我还是没成功,简直见鬼了!你能写个博客仔细说下吗?我相信很多人都需要这个###### 下面这一步你做了吗? 对于Windows 2000、XP、2003,点击控制面板->系统->高级->环境变量。在“系统变量”表单中点击叫做PATH的变量,然后编辑这个变量,把;C:\Python26加到它的结尾。当然,是Python所在的正确目录名。 ######啊!哈哈哈哈,谢谢您了,我配置好了!去掉了WSGIScriptAlias WSGIPythonPath这俩个,这个玩意弄了我几天了,前俩天搞得我都想回去用php了!真心谢谢######嗯,真的谢谢了,我也是这样弄的!WSGIScriptAlias /wsgi /django-app/SimpleCRM/SimpleCRM/wsgi.py WSGIPythonPath /django-app/SimpleCRM 你能解释下怎么改吗?我没安装django!我再好好整理下!######你应该说说有什么错误信息。######你可不可以把py, Apache和你的测试代码都放在一个硬盘符上试试看。感觉还是路径设置的问题。不要分开放置在C:,D:或者是E:上。######嗯,弄好了,谢谢,等下我写个博客去,免得向我一样的新手这样纠结!######Itenllij IDEA  可以用用######你在说什麽? ========================= title = Tomcat安装后配置问题 describe =     Tomcat安装后配置的过程中,配置好虚拟路径后在浏览器中输入“http://localhost/mldn/”,结果无法显示该网页。且上一步成功显示过的服务器首页也无法显示了。    诚问专业人士如何解决。 content = 是不是 http://locahost:8080######tomcat默认安装好的端口号是8080,######没有配置端口!###### 贴出server.xml看看哦 ###### http://localhost:8080/mldn/ 试试 ######检查本地是否启动成功 http://localhost:8080  是否可以正常访问,###### 服务器安装成功了,但服务器的虚拟目录配置没成功,输入http://localhost:8080/mldn/后的显示是下图,有尝试过把conf/web.xml文件中的listing下面的false改为true。 还请各位帮忙看看如何解决,谢谢! ######在服务中启动。Apache tomcat 6服务。你之前有没有配置过tomcat系统环境变量。如果有。这个是不会成功的。要修改一下到相应的路径~######差不多的问题哎,同样是进不去tomcat的那个小猫的画面,但是我在Eclipse中启动tomcat的话还是可以调用的,之前能用,我就改了下services.msc中的那个服务,具体啥原因我也不知道了
montos 2020-05-29 22:44:26 0 浏览量 回答数 0

云产品推荐

上海奇点人才服务相关的云产品 小程序定制 上海微企信息技术相关的云产品 国内短信套餐包 ECS云服务器安全配置相关的云产品 开发者问答 阿里云建站 自然场景识别相关的云产品 万网 小程序开发制作 视频内容分析 视频集锦 代理记账服务 阿里云AIoT