• 关于

    html5 ie

    的搜索结果

回答

意思就是IE可以识别、 条件注释的基本结构和HTML的注释(<!-- -->)是一样的。因此IE以外的浏览器将会把它们看作是普通的注释而完全忽略它们。 ###### 因为那些样式本来就在ie中无效啊 ###### IE对CSS的hack,可以用来区分IE各种版本   <!--[if !IE]><!--> 除IE外都可识别 <!--<![endif]-->   <!--[if IE]> 所有的IE可识别 <![endif]-->   <!--[if IE 5.0]> 只有IE5.0可以识别 <![endif]-->   <!--[if IE 5]> 仅IE5.0与IE5.5可以识别 <![endif]-->   <!--[if gt IE 5.0]> IE5.0以及IE5.0以上版本都可以识别 <![endif]-->   <!--[if IE 6]> 仅IE6可识别 <![endif]-->   <!--[if lt IE 6]> IE6以及IE6以下版本可识别 <![endif]-->   <!--[if gte IE 6]> IE6以及IE6以上版本可识别 <![endif]-->   <!--[if IE 7]> 仅IE7可识别 <![endif]-->   <!--[if lt IE 7]> IE7以及IE7以下版本可识别 <![endif]-->   <!--[if gte IE 7]> IE7以及IE7以上版本可识别 <![endif]--> 更新版本可以类推. ###### 引用来自“伊藤熊吉”的答案 因为那些样式本来就在ie中无效啊 没看清吧 if ie ###### 引用来自“飞炀”的答案 IE对CSS的hack,可以用来区分IE各种版本   <!--[if !IE]><!--> 除IE外都可识别 <!--<![endif]-->   <!--[if IE]> 所有的IE可识别 <![endif]-->   <!--[if IE 5.0]> 只有IE5.0可以识别 <![endif]-->   <!--[if IE 5]> 仅IE5.0与IE5.5可以识别 <![endif]-->   <!--[if gt IE 5.0]> IE5.0以及IE5.0以上版本都可以识别 <![endif]-->   <!--[if IE 6]> 仅IE6可识别 <![endif]-->   <!--[if lt IE 6]> IE6以及IE6以下版本可识别 <![endif]-->   <!--[if gte IE 6]> IE6以及IE6以上版本可识别 <![endif]-->   <!--[if IE 7]> 仅IE7可识别 <![endif]-->   <!--[if lt IE 7]> IE7以及IE7以下版本可识别 <![endif]-->   <!--[if gte IE 7]> IE7以及IE7以上版本可识别 <![endif]--> 更新版本可以类推. 我也是在网上找到这个了,类似。。怎么试  在ie中 css都没有生效 ###### 引用来自“javacc”的答案 引用来自“飞炀”的答案 IE对CSS的hack,可以用来区分IE各种版本   <!--[if !IE]><!--> 除IE外都可识别 <!--<![endif]-->   <!--[if IE]> 所有的IE可识别 <![endif]-->   <!--[if IE 5.0]> 只有IE5.0可以识别 <![endif]-->   <!--[if IE 5]> 仅IE5.0与IE5.5可以识别 <![endif]-->   <!--[if gt IE 5.0]> IE5.0以及IE5.0以上版本都可以识别 <![endif]-->   <!--[if IE 6]> 仅IE6可识别 <![endif]-->   <!--[if lt IE 6]> IE6以及IE6以下版本可识别 <![endif]-->   <!--[if gte IE 6]> IE6以及IE6以上版本可识别 <![endif]-->   <!--[if IE 7]> 仅IE7可识别 <![endif]-->   <!--[if lt IE 7]> IE7以及IE7以下版本可识别 <![endif]-->   <!--[if gte IE 7]> IE7以及IE7以上版本可识别 <![endif]--> 更新版本可以类推. 我也是在网上找到这个了,类似。。怎么试  在ie中 css都没有生效 <!--[if !IE]>不是<!--[if! IE]>
kun坤 2020-06-02 17:30:03 0 浏览量 回答数 0

回答

p> 意思就是IE可以识别、 条件注释的基本结构和HTML的注释(<!-- -->)是一样的。因此IE以外的浏览器将会把它们看作是普通的注释而完全忽略它们。 ###### 因为那些样式本来就在ie中无效啊 ###### IE对CSS的hack,可以用来区分IE各种版本   <!--[if !IE]><!--> 除IE外都可识别 <!--<![endif]-->   <!--[if IE]> 所有的IE可识别 <![endif]-->   <!--[if IE 5.0]> 只有IE5.0可以识别 <![endif]-->   <!--[if IE 5]> 仅IE5.0与IE5.5可以识别 <![endif]-->   <!--[if gt IE 5.0]> IE5.0以及IE5.0以上版本都可以识别 <![endif]-->   <!--[if IE 6]> 仅IE6可识别 <![endif]-->   <!--[if lt IE 6]> IE6以及IE6以下版本可识别 <![endif]-->   <!--[if gte IE 6]> IE6以及IE6以上版本可识别 <![endif]-->   <!--[if IE 7]> 仅IE7可识别 <![endif]-->   <!--[if lt IE 7]> IE7以及IE7以下版本可识别 <![endif]-->   <!--[if gte IE 7]> IE7以及IE7以上版本可识别 <![endif]--> 更新版本可以类推. ###### 引用来自“伊藤熊吉”的答案 因为那些样式本来就在ie中无效啊 没看清吧 if ie ###### 引用来自“飞炀”的答案 IE对CSS的hack,可以用来区分IE各种版本   <!--[if !IE]><!--> 除IE外都可识别 <!--<![endif]-->   <!--[if IE]> 所有的IE可识别 <![endif]-->   <!--[if IE 5.0]> 只有IE5.0可以识别 <![endif]-->   <!--[if IE 5]> 仅IE5.0与IE5.5可以识别 <![endif]-->   <!--[if gt IE 5.0]> IE5.0以及IE5.0以上版本都可以识别 <![endif]-->   <!--[if IE 6]> 仅IE6可识别 <![endif]-->   <!--[if lt IE 6]> IE6以及IE6以下版本可识别 <![endif]-->   <!--[if gte IE 6]> IE6以及IE6以上版本可识别 <![endif]-->   <!--[if IE 7]> 仅IE7可识别 <![endif]-->   <!--[if lt IE 7]> IE7以及IE7以下版本可识别 <![endif]-->   <!--[if gte IE 7]> IE7以及IE7以上版本可识别 <![endif]--> 更新版本可以类推. 我也是在网上找到这个了,类似。。怎么试  在ie中 css都没有生效 ###### 引用来自“javacc”的答案 引用来自“飞炀”的答案 IE对CSS的hack,可以用来区分IE各种版本   <!--[if !IE]><!--> 除IE外都可识别 <!--<![endif]-->   <!--[if IE]> 所有的IE可识别 <![endif]-->   <!--[if IE 5.0]> 只有IE5.0可以识别 <![endif]-->   <!--[if IE 5]> 仅IE5.0与IE5.5可以识别 <![endif]-->   <!--[if gt IE 5.0]> IE5.0以及IE5.0以上版本都可以识别 <![endif]-->   <!--[if IE 6]> 仅IE6可识别 <![endif]-->   <!--[if lt IE 6]> IE6以及IE6以下版本可识别 <![endif]-->   <!--[if gte IE 6]> IE6以及IE6以上版本可识别 <![endif]-->   <!--[if IE 7]> 仅IE7可识别 <![endif]-->   <!--[if lt IE 7]> IE7以及IE7以下版本可识别 <![endif]-->   <!--[if gte IE 7]> IE7以及IE7以上版本可识别 <![endif]--> 更新版本可以类推. 我也是在网上找到这个了,类似。。怎么试  在ie中 css都没有生效 <!--[if !IE]>不是<!--[if! IE]>
kun坤 2020-06-20 11:02:34 0 浏览量 回答数 0

回答

方式一:Coding JavaScript <!--[if lt IE 9]> <script> (function() { if (! /*@cc_on!@*/ 0) return; var e = "abbr, article, aside, audio, canvas, datalist, details, dialog, eventsource, figure, footer, header, hgroup, mark, menu, meter, nav, output, progress, section, time, video".split(', '); var i= e.length; while (i--){ document.createElement(e[i]) } })() </script> <![endif]--> 如果是IE9以下的IE浏览器将创建HTML5标签, 这样非IE浏览器就会忽视这段代码,也就不会有无谓的http请求了。 第二种方法:使用Google的html5shiv包(推荐) <!--[if lt IE 9]> <script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script> <![endif]--> 但是不管使用以上哪种方法,都要初始化新标签的CSS.因为HTML5在默认情况下表现为内联元素,对这些元素进行布局我们需要利用CSS手工把它们转为块状元素方便布局 /*html5*/ article,aside,dialog,footer,header,section,footer,nav,figure,menu{display:block} 但是如果ie6/7/8 禁用脚本的用户,那么就变成了无样式的"白板"网页,我们该怎么解决呢? 我们可以参照facebook的做法,即引导用户进入带有noscript标识的 “/?_fb_noscript=1”页面,用 html4 标签替换 html5 标签,这要比为了保持兼容性而写大量 hack 的做法更轻便一些。 <!--[if lte IE 8]> <noscript> <style>.html5-wrappers{display:none!important;}</style> <div class="ie-noscript-warning">您的浏览器禁用了脚本,请<a href="">查看这里</a>来启用脚本!或者<a href="/?noscript=1">继续访问</a>. </div> </noscript> <![endif]--> 这样可以引导用户开启脚本,或者直接跳转到HTML4标签设计的界面。
a123456678 2019-12-02 02:21:18 0 浏览量 回答数 0

问题

页面中hack一个cdn的html5.js不能使用,但是放到项目中就可以用?

做网页时因为用的了html5标签,hack了一个html5.js &lt;!--[if lt IE 9]&gt; &lt;script src="//cdn.bootcss.com/html5shiv/r29/html5.min.j...
杨冬芳 2019-12-01 19:41:47 1521 浏览量 回答数 1

问题

JavaScript获取元素节点,兼容IE低版本浏览器,但是IE7中无法识别ul标签下的li标签之后的span和a标签。

1.描述你的问题想写JavaScript原生获取元素节点,兼容IE低版本浏览器。但是IE7中无法识别ul标签下的li标签之后的span和a标签。也就是HTML中注释的部分。3.贴上报错信息执行代码后,谷歌和火狐浏览器、IE8及以上依次弹出6...
杨冬芳 2019-12-01 20:07:11 1131 浏览量 回答数 1

问题

IE6滴FUCK-BUG-HTML报错

"1 IE6中绝对定位位置错误 BUG 在ie6中 . 如果参照物没有触发haslayout . 那么“绝对定位的容器”的left和bottom就会有问题 解决 在“相对定位的父容器”上加入 zoom:1 来触发ie的hasla...
montos 2020-05-31 22:59:24 0 浏览量 回答数 1

回答

viewport:http://www.cnblogs.com/pigtail/archive/2013/03/15/2961631.html keywords、content-type,description这些是主要的,content-type定义类型和编码,给浏览器使用 eywords,description主要给搜索引擎用的,定义关键字和页面的描述 其他的随便搞,看浏览器的支持了,如X-UA-Compatible这个是给ie用的,强制ie以那种兼容模式打开,以ie5或者ie6,ie7什么的 还有``是360独有的,不管页面文档模式如何,将以webkit核心解析。
云栖技术 2019-12-02 02:37:07 0 浏览量 回答数 0

问题

web直传兼容性问题

访问:oss-demo.aliyuncs.com/oss-h5-upload-js-direct/index.html?spm=5176.doc31925.2.2.SJWl0Q ie11, edge, chrome54...
李化贝 2019-12-01 21:32:52 2552 浏览量 回答数 3

回答

关键看是否满足你的兼容需求 官方说的是兼容ie8+ & chrome & firefox 实际上ie8,9本身对css3和html5支持并不是特别好,所以这两个版本的ie多多少少还是有问题,需要一些其他兼容插件配合
杨冬芳 2019-12-02 02:44:57 0 浏览量 回答数 0

回答

png24位的图片在iE6浏览器上出现背景 解决方案:做成PNG8,也可以引用一段脚本处理. 浏览器默认的margin和padding不同 解决方案:加一个全局的 *{margin:0;padding:0;} 来统一。 IE6双边距bug:在IE6下,如果对元素设置了浮动,同时又设置了margin-left或margin-right,margin值会加倍。 这种情况之下IE会产生20px的距离 解决方案:在float的标签样式控制中加入 _display:inline; 将其转化为行内属性。( _ 这个符号只有ie6会识别) 渐进识别的方式,从总体中逐渐排除局部。 首先,巧妙的使用“\9”这一标记,将IE游览器从所有情况中分离出来。 接着,再次使用 "+" 将IE8和IE7、IE6分离开来,这样IE8已经独立识别。 5.IE下,可以使用获取常规属性的方法来获取自定义属性,也可以使用 getAttribute() 获取自定义属性;Firefox下,只能使用getAttribute()获取自定义属性 解决方法:统一通过getAttribute()获取自定义属性 IE下,event对象有 x、y 属性,但是没有 pageX、pageY属性; Firefox下,event对象有 pageX、pageY 属性,但是没有 x、y 属性 解决方法:(条件注释)缺点是在IE浏览器下可能会增加额外的HTTP请求数。 Chrome 中文界面下默认会将小于 12px 的文本强制按照 12px 显示 解决方法:可通过加入 CSS 属性 -webkit-text-size-adjust: none; 解决 超链接访问过后 hover 样式就不出现了,被点击访问过的超链接样式不在具有 hover 和 active 了 解决方法:改变CSS属性的排列顺序 L-V-H-A 怪异模式问题:漏写 DTD 声明,Firefox 仍然会按照标准模式来解析网页,但在 IE 中会触发怪异模式。为避免怪异模式给我们带来不必要的麻烦,最好养成书写 DTD 声明的好习惯。现在可以使用html5 推荐的写法: 上下margin重合问题:ie和ff都存在,相邻的两个div的margin-left和margin-right不会重合,但是margin-top和margin-bottom却会发生重合。 解决方法:养成良好的代码编写习惯,同时采用margin-top或者同时采用margin-bottom。 ie6对png图片格式支持不好 解决方案:引用一段脚本处理
小柯卡力多 2019-12-02 03:21:58 0 浏览量 回答数 0

问题

为何在IE中给DIV设置magin-top会出现滚动条

我用的IE版本挺高,是IE11,下面是我的代码,很简单,我margin-top:100px,居然这样都会出现滚动条,那岂不是一用margin-top就得出滚动条? &lt;!DOCTYPE HTML PUBLIC "-//W3C//DTD...
小旋风柴进 2019-12-01 20:22:21 1133 浏览量 回答数 1

问题

解决IE8不支持html5标签最好解决办法?

网上有的说使用html5shiv,但是国内网络不能打开goolge网站。 看到一种facebook的做法,不知这样适合国情吗,大家一般是怎么解决的? <!--[if lte IE 8]> <noscript> ...
a123456678 2019-12-01 19:32:40 948 浏览量 回答数 1

问题

FLASH播放器,在IE浏览器下显示请确定您的域名已完成备案和CNAME绑定

您好,上周已经测试好接口上线使用了。但是系统的使用者是医生,大多习惯于微软的IE浏览器。当用IE浏览器打开视频点播的播放器时,会报错 FLASH播放器代码如下: 其他的浏览器正常,目前IE有问题。请帮忙给出解决方案,...
单孔腹腔镜 2019-12-01 18:51:26 13954 浏览量 回答数 0

问题

2.1.4.2浏览器相关功能函数

2.浏览器相关函数 2.1 J_IE_Create (链接地址,[尝试抓取:否],[是否等待:是],[浏览器类型]) 作用:创建一个IE窗口,返回一个窗口的对象 返回值:返回浏览器对象ÿ...
福利达人 2019-12-01 21:58:33 2173 浏览量 回答数 0

问题

在html中设置content="IE=edge"在IE中测试中只用测试edge模式下吗

把我制作网页 在IE11的仿真中进行模拟,分别模拟Edge,10,9,8,7,5在不同模拟中出现不同的问题, 如果在网页中设置 , 只用测试edge的模式,并修改,可以吗...
杨冬芳 2019-12-01 19:38:37 1059 浏览量 回答数 1

问题

hello_code · 2015年06月15日回答 在html中设置content="IE=edge"在IE中测试中只用测试edge模式下吗?

把我制作网页 在IE11的仿真中进行模拟,分别模拟Edge,10,9,8,7,5在不同模拟中出现不同的问题, 如果在网页中设置 , 只用测试edge的模式,并修改,可以吗...
杨冬芳 2019-12-01 20:03:34 951 浏览量 回答数 1

问题

如何禁用多点触屏里IE8以上的缩放功能?

如何禁用xp,win7触屏设备的ie8以上浏览器放大缩小功能?搜到些答案:https://social.msdn.microsoft.com/Forums/ie/en-US/0e590444-50b8-4019-a7f2-a74f8f35f...
杨冬芳 2019-12-01 20:09:36 1125 浏览量 回答数 1

回答

既然都是从IE6访问的 那就直接从网页代码入手 这是从阿里云首页源码中截取的一段代码 <!--[if lt IE 8]>     <script type="text/javascript" src="//g.alicdn.com/??aliyun/www-dpl/0.2.28/knight/js/iconfont-ie7.js"></script> <![endif]--> <!--[if lt IE 9]>     <link type="text/css" rel="stylesheet" href="//g.alicdn.com/??aliyun/www-dpl/0.2.28/knight/css/widget/header-ie.css" />     <script type="text/javascript" src="//g.alicdn.com/??aliyun/www-dpl/0.2.28/knight/js/html5.js"></script> <![endif]--> 意思是如果访问的是IE8就加载g.alicdn.com/??aliyun/www-dpl/0.2.28/knight/js/iconfont-ie7.js 这个js文件 同样可以在自己的网页上if ie6 加载东西 自己写个东西,把ie6访问的用户跳转到另一个网页或者直接空白网页给他吃。 代码自己写哦! 当然这也就造成所以用ie6访问的用户都无法正常访问了。 这年头没多少正常用户用IE6了。 ------------------------- 回 1楼(go696) 的帖子 建议,可以弄一个网页提示他 你的网站不支持IE6的访问了  建议这个页面可以直接放在oss上 ,不占你ECS的资源 既然对方的目的是攻击,这个提示网页做的越小越好
go696 2019-12-02 02:15:37 0 浏览量 回答数 0

问题

怎样让bootstrap兼容ie浏览器,引用html5shiv.min.js无效:报错

ie浏览器不能兼容bootstrap框架 ,怎样解决...
kun坤 2020-06-14 06:42:27 0 浏览量 回答数 1

问题

怎样让bootstrap兼容ie浏览器,引用html5shiv.min.js无效 - 前端报错

ie浏览器不能兼容bootstrap框架 ,怎样解决...
montos 2020-06-02 12:41:04 0 浏览量 回答数 1

回答

首先video.js是一个HTML5播放器,而IE 8 不支持HTML5,所有它将尝试使用Flash播放(那个object是video.js尝试用Flash播放该视频生成的)。 所以,保证video-js.swf路径一定要正确!另外,还有一个小坑,确保设置了poster image,否则Flash player可能不会工作(这是 stackoverflow 上看到的,我没验证过)。最后,再提供另外两款支持IE8 的视频播放器:Mediaelement PlayerjPlayer
a123456678 2019-12-02 02:25:53 0 浏览量 回答数 0

问题

关于HTML5 canvas标签 和IE8的兼容问题,求大神....?报错

canvas在ie8以及低版本中都不被支持,可以下载excanvas.js来通过vml进行兼容,google的excanvas要求在ie下必须通过window.onload()加载完之后再去调用canvas。 但是现在的问题是...
爱吃鱼的程序员 2020-06-22 13:46:54 0 浏览量 回答数 1

问题

如何让 ie6/7/8 兼容html5标签

如:section .timeline{width:500px;}如果想兼容IE6/7/8,需要怎么处理呢?只能改回div么?...
a123456678 2019-12-01 19:27:10 981 浏览量 回答数 1

回答

https://github.com/walkor/web-msg-sender 这个绝对是你想要的,websocket+workerman实现的 DEMO: 后台发送消息的页面  http://workerman.net:3333/ 用户接收消息的页面  http://workerman.net/web-msg-sender.html 原理:用户打开页面后浏览器会自动向后端服务器发送一个websocket(浏览器支持HTML5或者Flash就可以)连接,后端hold住这些连接,当想推送消息给浏览器时,向这些websocket连接写数据即可。 优点:  1. 非轮询,性能很高,普通的服务器即可维持上万的连接  2. 实时性好  3. 兼容各种浏览器包括ie6(客户端支持flash或者html5任意一个就行) ######才是######osc搜索icomet,应该可以满足你的要求######你指的是PC端还是手机端啊######后台做判断,如果登陆会有一个状态的改变,并且只给登陆的用户推送相应内容,推送给用户######我说的是 web版的 html+javascript+php 不使用ajax######长连接?######websocket######用JQ+PHP###### 不用ajax基本别想了。websocket是html5的。考虑IE6-9小心点。 ######回复 @yak : 天朝没了都不带没IE67的。。######回复 @yak : 你预计吧...######回复 @屈超 : 预计一下,天朝ie67死光会发生在哪一年######还是让ie6-7死掉吧...######浏览器支持的话就用webservice,不支持的话可以用WebSocketMain.swf代替实现!###### 引用来自“domr”的评论 https://github.com/walkor/web-msg-sender 这个绝对是你想要的,websocket+workerman实现的 DEMO: 后台发送消息的页面  http://workerman.net:3333/ 用户接收消息的页面  http://workerman.net/web-msg-sender.html 原理:用户打开页面后浏览器会自动向后端服务器发送一个websocket(浏览器支持HTML5或者Flash就可以)连接,后端hold住这些连接,当想推送消息给浏览器时,向这些websocket连接写数据即可。 优点:  1. 非轮询,性能很高,普通的服务器即可维持上万的连接  2. 实时性好  3. 兼容各种浏览器包括ie6(客户端支持flash或者html5任意一个就行) 谢谢,这个东西 怎么去使用 详细一点告诉我好吗
爱吃鱼的程序员 2020-06-03 20:57:40 0 浏览量 回答数 0

问题

GSAP js动画性能优于jQuery的原理是什么?

这是官方网址,貌似GSAP在chrome or firefox or opera等浏览器是调用HTML5原生的动画变换,但在官方给出的示例页面中(http://www.greensock.com/js/speed.html),GSAP在IE...
杨冬芳 2019-12-01 19:58:38 1020 浏览量 回答数 1

回答

不要用window.open,会被浏览器拦截,相当于那种弹窗广告,看过吧? 其实除了IE之外,Html5有个新的属性叫download,直接就可以实现下载。不过不支持IE。用之前判断一下alink.download是否存在就可以了。不存在就用IE的方法,如果不想用新窗口的方法也可以用iframe的。 function save() { var img = document.getElementById("testImg"); var alink = document.createElement("a"); a.href = img.src; a.download = "testImg.jpg"; a.click(); }
a123456678 2019-12-02 02:04:45 0 浏览量 回答数 0

回答

新特性: 拖拽释放(拖放)API 语义化更好的内容标签(页眉,导航,页脚,旁边,文章,部分) 音频,视频API(音频,视频) 画布(画布)API 地理(地理位置)API 本地离线存储localStorage长期存储数据,浏览器关闭后数据不丢失; sessionStorage的数据在浏览器关闭后自动删除 表单控件,日历,日期,时间,电子邮件,网址,搜索 新的技术webworker,websocket,地理位置 可移除的元素: 纯表现的元素:basefont,大,center,font,s,strike,tt,u; 对可用产生可能影响的元素:frame,frameset,noframes; 支持HTML5新标签: IE8 / IE7 / IE6支持通过document.createElement方法产生的标签,可以利用这一特性让这些浏览器支持HTML5新标签,浏览器支持新标签后,还需要添加标签样式的样式: 当然最好的方式是直接使用成熟的框架,使用最多的是html5shim框架 <!- [如果是IE 9,则>> 脚本> src =“ http://html5shim.googlecode.com/svn/trunk/html5.js”; </ script> <![endif] ->
茶什i 2019-12-02 03:16:12 0 浏览量 回答数 0

问题

播放器插件videojs在ie8下无法播放?

项目用的是html5的video播放视频,使用的videojs,听说他兼容所有浏览器,但项目实际在IE8下进行测试发现无法播放,在官网上查看文档发现都是英文,实在看不懂所以想大家求助,大家有没有用过这个插件。...
a123456678 2019-12-01 19:32:36 1438 浏览量 回答数 1

回答

新特性: HTML5 现在已经不是 SGML 的子集,主要是关于图像,位置,存储,多任务等功能的增加。 1. 拖拽释放(Drag and drop) API 2. 语义化更好的内容标签(header,nav,footer,aside,article,section) 3. 音频、视频API(audio,video) 4. 画布(Canvas) API 5. 地理(Geolocation) API 6. 本地离线存储 localStorage 长期存储数据,浏览器关闭后数据不丢失; 7. sessionStorage 的数据在浏览器关闭后自动删除 8. 表单控件,calendar、date、time、email、url、search 9. 新的技术webworker, websocket, Geolocation 移除的元素: 1. 纯表现的元素:basefont,big,center,font, s,strike,tt,u; 2. 对可用性产生负面影响的元素:frame,frameset,noframes; 支持HTML5新标签: 1. IE8/IE7/IE6支持通过 document.createElement 方法产生的标签,可以利用这一特性让这些浏览器支持 HTML5 新标签,浏览器支持新标签后,还需要添加标签默认的样式(当然最好的方式是直接使用成熟的框架、使用最多的是html5shiv框架): 如何区分: DOCTYPE声明新增的结构元素、功能元素
小柯卡力多 2019-12-02 03:21:59 0 浏览量 回答数 0

问题

IE11 不支持 FileReader.readAsBinaryString():报错

用HTML5做文件上传,遇见一个问题. 在IE11下,FileReader不支持readAsBinaryString这个方法,不知道有没有其他替代的方法.我readAsArrayBuffer方法后,能上传.但是上传的文件是破损的,也就...
kun坤 2020-06-07 14:46:15 0 浏览量 回答数 1

云产品推荐

上海奇点人才服务相关的云产品 小程序定制 上海微企信息技术相关的云产品 国内短信套餐包 ECS云服务器安全配置相关的云产品 开发者问答 阿里云建站 自然场景识别相关的云产品 万网 小程序开发制作 视频内容分析 视频集锦 代理记账服务 阿里云AIoT