• 关于

    加载php扩展

    的搜索结果

回答

可能是你的cli和cgi的php加载的不是同一个php.ini文件,你只给cgi加载了你的扩展。可以用如下方法看看具体的差异执行一下$ php -m 看看有没有你编写的扩展,从你的问题看是没有的。再执行下 $ php -i | grep ini 看看加载的是哪个php.ini文件。同时在web页面中执行个<?php phpinfo();看看这里加载的是那个ini文件。
落地花开啦 2019-12-02 02:42:39 0 浏览量 回答数 0

问题

centos7 安装php扩展

今天在Centos7使用php时发现mbstring扩展没有安装,于是使用yum instll php-mbstring安装成后发现/etc/php.d/目录下已经有了mbstring.ini文件并且里面也有一行extension=mbst...
a123456678 2019-12-01 20:11:43 1070 浏览量 回答数 1

回答

这个主要是扩展的加载问题。 1、没有显示的哪一台,以前是不是曾经配置过PHP环境?如果是,你要重新确定一下现在PHP的配置环境的PHP.INI文件不是在你认为的路径上。 2、检查2台机器上的php.ini配置,主要看扩展组件的配置段 3、确定扩展包拷贝到了正确的路径中 其它... 等我想到再说。 php.exe -v 应该会出警告,很久不用windows一直在mac和linux服务器上工作,都不知道windows上是个什么情况。 应该会出警告,很久不用windows一直在mac和linux服务器上工作,都不知道windows上是个什么情况。 c:\php54>php.exe -v PHP 5.4.6 (cli) (built: Aug 15 2012 21:16:03) Copyright (c) 1997-2012 The PHP Group Zend Engine v2.4.0, Copyright (c) 1998-2012 Zend Technologies ######在没有扩展的那台机器上看看php -v 看一下Php.ini是载入的哪里的文件,看看里面的extension语句里面有没加载memcache的扩展dll###### ![image.png](https://ucc.alicdn.com/pic/developer-ecology/d569b311c8b644b38b05c8a8e5f6115b.png) apache和php的目录位置也都相同 ###### 两边机器都看一下c:/php54/php.ini 看看此文件在不在 这个主要是扩展的加载问题。 1、没有显示的哪一台,以前是不是曾经配置过PHP环境?如果是,你要重新确定一下现在PHP的配置环境的PHP.INI文件不是在你认为的路径上。 2、检查2台机器上的php.ini配置,主要看扩展组件的配置段 3、确定扩展包拷贝到了正确的路径中 其它... 等我想到再说。   两个目录 (1) c:\php54   (2) c:\apache24 php.ini 在c:\php54\下 扩展dll都在c:\php54\ext\下 httpd.conf在C:\Apache24\conf下 完全复制上面两个目录到另外一台机器上运行;echo phpinfo(); 不一样。 这个问题确实很莫名其妙,但却是如此! ###### 或许有的扩展放在 C:\WINDOWS 下没有拷贝. 或许这些扩展的加载需要重启.
一枚小鲜肉帅哥 2020-05-28 10:03:23 0 浏览量 回答数 0

阿里云试用中心,为您提供0门槛上云实践机会!

100+款试用云产品,最长免费试用12个月!拨打95187-1,咨询专业上云建议!

问题

经过phpize正确编译完扩展确加载不到,什么原因?

昨天正在在linux下 source code compile PHP 扩展遇到了一个问题,还未参透,还请能指点一下apache mysql php 都编译安装完成了,PHP程序文也能执行,,当运行某一个PHP文件时提示 mbstring ...
落地花开啦 2019-12-01 19:59:46 997 浏览量 回答数 1

回答

这个主要是扩展的加载问题。 1、没有显示的哪一台,以前是不是曾经配置过PHP环境?如果是,你要重新确定一下现在PHP的配置环境的PHP.INI文件不是在你认为的路径上。 2、检查2台机器上的php.ini配置,主要看扩展组件的配置段 3、确定扩展包拷贝到了正确的路径中 其它... 等我想到再说。   ######。。。你确认所有扩展都拷贝了?###### php.exe -v 应该会出警告,很久不用windows一直在mac和linux服务器上工作,都不知道windows上是个什么情况。 ###### 引用来自“妖魔舞”的答案 。。。你确认所有扩展都拷贝了? 当然了,是完全拷贝的! ######哪有这么邪乎。。。###### 引用来自“bundles”的答案 php.exe -v 应该会出警告,很久不用windows一直在mac和linux服务器上工作,都不知道windows上是个什么情况。 c:\php54>php.exe -v PHP 5.4.6 (cli) (built: Aug 15 2012 21:16:03) Copyright (c) 1997-2012 The PHP Group Zend Engine v2.4.0, Copyright (c) 1998-2012 Zend Technologies ######在没有扩展的那台机器上看看php -v 看一下Php.ini是载入的哪里的文件,看看里面的extension语句里面有没加载memcache的扩展dll###### apache和php的目录位置也都相同 ###### 两边机器都看一下c:/php54/php.ini 看看此文件在不在 ###### 引用来自“TavenLi”的答案 这个主要是扩展的加载问题。 1、没有显示的哪一台,以前是不是曾经配置过PHP环境?如果是,你要重新确定一下现在PHP的配置环境的PHP.INI文件不是在你认为的路径上。 2、检查2台机器上的php.ini配置,主要看扩展组件的配置段 3、确定扩展包拷贝到了正确的路径中 其它... 等我想到再说。   两个目录 (1) c:\php54   (2) c:\apache24 php.ini 在c:\php54\下 扩展dll都在c:\php54\ext\下 httpd.conf在C:\Apache24\conf下 完全复制上面两个目录到另外一台机器上运行;echo phpinfo(); 不一样。 这个问题确实很莫名其妙,但却是如此! ###### 或许有的扩展放在 C:\WINDOWS 下没有拷贝. 或许这些扩展的加载需要重启.
montos 2020-05-31 15:17:54 0 浏览量 回答数 0

回答

这个主要是扩展的加载问题。 1、没有显示的哪一台,以前是不是曾经配置过PHP环境?如果是,你要重新确定一下现在PHP的配置环境的PHP.INI文件不是在你认为的路径上。 2、检查2台机器上的php.ini配置,主要看扩展组件的配置段 3、确定扩展包拷贝到了正确的路径中 其它... 等我想到再说。   ######。。。你确认所有扩展都拷贝了?###### php.exe -v 应该会出警告,很久不用windows一直在mac和linux服务器上工作,都不知道windows上是个什么情况。 ###### 引用来自“妖魔舞”的答案 。。。你确认所有扩展都拷贝了? 当然了,是完全拷贝的! ######哪有这么邪乎。。。###### 引用来自“bundles”的答案 php.exe -v 应该会出警告,很久不用windows一直在mac和linux服务器上工作,都不知道windows上是个什么情况。 c:\php54>php.exe -v PHP 5.4.6 (cli) (built: Aug 15 2012 21:16:03) Copyright (c) 1997-2012 The PHP Group Zend Engine v2.4.0, Copyright (c) 1998-2012 Zend Technologies ######在没有扩展的那台机器上看看php -v 看一下Php.ini是载入的哪里的文件,看看里面的extension语句里面有没加载memcache的扩展dll###### apache和php的目录位置也都相同 ###### 两边机器都看一下c:/php54/php.ini 看看此文件在不在 ###### 引用来自“TavenLi”的答案 这个主要是扩展的加载问题。 1、没有显示的哪一台,以前是不是曾经配置过PHP环境?如果是,你要重新确定一下现在PHP的配置环境的PHP.INI文件不是在你认为的路径上。 2、检查2台机器上的php.ini配置,主要看扩展组件的配置段 3、确定扩展包拷贝到了正确的路径中 其它... 等我想到再说。   两个目录 (1) c:\php54   (2) c:\apache24 php.ini 在c:\php54\下 扩展dll都在c:\php54\ext\下 httpd.conf在C:\Apache24\conf下 完全复制上面两个目录到另外一台机器上运行;echo phpinfo(); 不一样。 这个问题确实很莫名其妙,但却是如此! ###### 或许有的扩展放在 C:\WINDOWS 下没有拷贝. 或许这些扩展的加载需要重启.
kun坤 2020-06-07 09:14:32 0 浏览量 回答数 0

问题

经过phpize正确编译完扩展确加载不到什么情况..

昨天正在在linux下 source code compile PHP 扩展遇到了一个问题,还未参透,还请能指点一下apache mysql php 都编译安装完成了,PHP程序文也能执行,,当运行某一个PHP文件时提示 mbstring ...
a123456678 2019-12-01 20:05:00 789 浏览量 回答数 1

问题

linux下安装php的memcache扩展

linux下安装php的memcached扩展,没有任何报错信息,已修改php.ini文件。重启nginx后发现phpinfo中并没有显示memcached模块的扩展。安装其他php的扩展也是这个样子,没有报错但是不加载扩展。...
a123456678 2019-12-01 20:11:22 1044 浏览量 回答数 1

回答

" 这个主要是扩展的加载问题。 1、没有显示的哪一台,以前是不是曾经配置过PHP环境?如果是,你要重新确定一下现在PHP的配置环境的PHP.INI文件不是在你认为的路径上。 2、检查2台机器上的php.ini配置,主要看扩展组件的配置段 3、确定扩展包拷贝到了正确的路径中 其它... 等我想到再说。   ######。。。你确认所有扩展都拷贝了?###### php.exe -v 应该会出警告,很久不用windows一直在mac和linux服务器上工作,都不知道windows上是个什么情况。 ###### 引用来自“妖魔舞”的答案 。。。你确认所有扩展都拷贝了? 当然了,是完全拷贝的! ######哪有这么邪乎。。。###### 引用来自“bundles”的答案 php.exe -v 应该会出警告,很久不用windows一直在mac和linux服务器上工作,都不知道windows上是个什么情况。 c:\php54>php.exe -v PHP 5.4.6 (cli) (built: Aug 15 2012 21:16:03) Copyright (c) 1997-2012 The PHP Group Zend Engine v2.4.0, Copyright (c) 1998-2012 Zend Technologies ######在没有扩展的那台机器上看看php -v 看一下Php.ini是载入的哪里的文件,看看里面的extension语句里面有没加载memcache的扩展dll###### apache和php的目录位置也都相同 ###### 两边机器都看一下c:/php54/php.ini 看看此文件在不在 ###### 引用来自“TavenLi”的答案 这个主要是扩展的加载问题。 1、没有显示的哪一台,以前是不是曾经配置过PHP环境?如果是,你要重新确定一下现在PHP的配置环境的PHP.INI文件不是在你认为的路径上。 2、检查2台机器上的php.ini配置,主要看扩展组件的配置段 3、确定扩展包拷贝到了正确的路径中 其它... 等我想到再说。   两个目录 (1) c:\php54   (2) c:\apache24 php.ini 在c:\php54\下 扩展dll都在c:\php54\ext\下 httpd.conf在C:\Apache24\conf下 完全复制上面两个目录到另外一台机器上运行;echo phpinfo(); 不一样。 这个问题确实很莫名其妙,但却是如此! ###### 或许有的扩展放在 C:\WINDOWS 下没有拷贝. 或许这些扩展的加载需要重启. " ![image.png](https://ucc.alicdn.com/pic/developer-ecology/5512982bf38f453ab0adb291a5d5339e.png)
montos 2020-05-30 23:17:53 0 浏览量 回答数 0

问题

linux系统 无法加载mysql扩展。请检查您的PHP配置。

linux系统centos 6.5 64位安装wdcp V3一键安装包后进入phpmyadmin后台提示无法加载mysql扩展。请检查您的PHP配置。 使用的是 PHP 7.0.6;mysql 5.6.30。...
maominghome 2019-12-01 21:29:18 4531 浏览量 回答数 2

回答

extension=phpintl.dll 表示php加载加载这个这个扩展。在php.ini文件里设置。当前哪个php.ini文件起效,可以用phpinfo()函数,在php文件打印出来看下。 在php.ini里还有个配置:extensiondir='你的扩展路径名' 这里面定义了extension用到的dll文件路径。路径定义的是apache/bin目录,就要把dll拷贝到这个里面
落地花开啦 2019-12-02 02:46:39 0 浏览量 回答数 0

回答

Segmentation fault一般是挂了啊~如果没有扩展之前是好的,加载扩展就不行了,那么需要确认这个扩展是否有问题,比如源代码是否ok,是否兼容php的版本需要调试一下看问题出在哪了
杨令云 2019-12-02 00:45:02 0 浏览量 回答数 0

问题

PHP安装imagick扩展问题:已经安装但是没有扩展中的任何方法?

phpinfo已经看到成功加载了imagick扩展,但是我使用get_extension_funcs('imagick');却没有方法。我是这样按照的:首先使用yum安装了 yum install -y ImageMagick ImageM...
落地花开啦 2019-12-01 20:05:43 1522 浏览量 回答数 2

回答

Q: 函数计算 php runtime 是什么? A: 请参考官方文档: php 函数入口 php 运行环境 Q: 函数计算 php runtime 支持 http trigger 吗? A: 支持, 详情见 php HTTP 触发器的函数入口 Q: php runtime 能使用第三方扩展吗? A: 能 php 自定义扩展 php runtime 动态加载卸载内置扩展 Q: php runtime 内置的table store php sdk 使用有问题 A: 原因是内置protobuf扩展和table store 依赖的php 实现的protobuf有冲突,具体解法请参考:php runtime 动态加载卸载内置扩展;同时,针对php runtime 动态加载卸载内置扩展这个话题,鼓励用户使用环境变量来裁剪不必要的扩展来优化runtime的启动速度 Q: php runtime 对异常处理严格,比如级别较低的notice就会抛出异常,导致某些第三方库(aliyun-openapi-php-sdk)不能使用怎么办? A: 有解法,详情请参考:函数计算PHP Runtime - exception 处理 Q: php runtime 能驱动php 框架吗? A: 能,请参考 十分钟上线-函数计算玩转 WordPress 十分钟上线-函数计算&Laravel的那些事儿 用阿里云函数计算部署thinkphp5.1 云计算的1024种玩法- 1小时用阿里云函数计算部署一个 ServerLess 化的按量版 WordPress Q: 使用php runtime http trigger出现Cannot modify header information - headers already sent by (output started at ... 怎么处理? A:php runtime 中 headers already sent 问题解决方案 Q: 使用php runtime http trigger想更改 session 目录怎么处理? A:php runtime 中 headers already sent 问题解决方案 更改session 目录部分 Q: php runtime开发web时, 怎么支持rewrite? A:php runtime 中 http web 中 rewrite 浅解和方案 Q: php runtime 除了内置的扩展,想使用 php-gd 等其他php扩展怎么办? A: 函数计算 php runtime 编译非内置的扩展 Q: php runtime 两个php 文件简单require_once使用sample a.php <?php $appcode = 123456; class Foo { public $name = 'FooClass'; function sayhi() { print 'Foo say hello!'; } } $foo = new Foo; b.php <?php require_once __DIR__ . '/a.php'; function handler($event, $context) { echo $GLOBALS['appcode'] . PHP_EOL; $GLOBALS['foo']->sayhi(); $foo2 = new Foo; $foo2->sayhi(); return $GLOBALS['appcode']; }
保持可爱mmm 2020-04-15 23:05:53 0 浏览量 回答数 0

回答

逐一关闭php扩展,发现是php_curl加载时报错,而且phpinfo()中curl没有加载上解决办法:第一种方法:将php安装目录下的libeay32.dll,libssh2.dll,php5ts.dll,php_curl.dll,ssleay32.dll 复制到system32目录下第二种方法:在httpd.conf 中加载如下依赖文件LoadFile D:/wamp/php/php5ts.dll LoadFile D:/wamp/php/libeay32.dll LoadFile D:/wamp/php/ssleay32.dll LoadFile D:/wamp/php/libssh2.dll这样配置后,Apache开启时不再弹出warning PHP Startup:
小旋风柴进 2019-12-02 02:01:35 0 浏览量 回答数 0

问题

centos php安装mcrypt扩展报错 Module 'mcrypt' a?报错

打算在服务器上设置一个计划任务定时执行一个php文件,测试的时候发现需要mcrypt支持,于是就安装了mcrypt扩展,php -m 查看确定已加载mcrypt扩展。   使用phpinfo查...
爱吃鱼的程序员 2020-06-22 13:19:46 0 浏览量 回答数 1

问题

安装ahm面板,模块扩展问题

安装ahm面板,安装phpMyAdmin模块,出现无法加载 mcrypt 扩展,请检查您的 PHP 配置。这个该怎么解决啊...
深蓝深蓝 2019-12-01 21:18:19 4236 浏览量 回答数 1

回答

1.报错提示是说明要64位版本的is not a valid Win32 application2.PHP Startup: Unable to load dynamic library 有时候明明是有这个扩展但是就是加载不了 而且之间都都好好的啊。为什么会这样。是因为他们都会加载依赖的DLL 但是因为window环境变量问题。加载不到解决办法。1.把依赖的dll 复制到%windir%system322.将PHP5的安装目录添加到%PATH%中。(推荐这种)3.还需要注意 nts ts() 版本搜索phpinfo Thread Safety (enable 是ts disable 是nts) 具体可以看phpinfo 搜索下 还要查看依赖运行库
落地花开啦 2019-12-02 01:53:11 0 浏览量 回答数 0

问题

php安装mongodb扩展 加载失败:报错

在centos7.4环境下,php7.0版本安装完扩展mongodb后,重启php-fpm时提示: /usr/local/php7/sbin/php-fpm: symbol lookup error: /usr/local/php7/li...
kun坤 2020-06-14 09:49:02 0 浏览量 回答数 0

问题

怎样让 php 在 cli 与 fpm 环境下运行时加载不同的扩展 ?

问题:由于开启了 xdebug 扩展, 导致使用 composer 时提示: You are running composer with xdebug enabled. This has a major impact on runtime ...
a123456678 2019-12-01 20:10:45 2159 浏览量 回答数 2

回答

首先你必须对php的扩展和版本区别有了解,在写代码的时候,要约定好应用需要的基本环境,在这个环境下进行开发,写好以后把这个约定告诉使用者。 并且也要清楚哪些扩展是php内置的,哪些是默认没有的,在使用默认没有的扩展之前,要用function_exists,extension_loaded,method_exists进行判断。 如果没有预先约定,也没有检测,你写的代码自己用眼睛扫一遍应该能知道需要哪些模块。 另外,某些ide比如PHPStrom,内置函数和大部分扩展函数着色也不一样,5.3版之前的函数和5.3以后的新函数代码着色不一样,如果应用要在5.2上运行,用它能发现这些问题。######花开兄, 竟然在这看到你的贴子哈, 你的问题我不懂, 给你友情顶一下吧.######有很多编辑器就可以啊,先把一个项目添加进去,也就是你的整个程序,等加载完了,就可以直接搜索到加载的类,方法,常量等等!!比如zend, netbeans 。。。。。。。
爱吃鱼的程序员 2020-06-03 18:03:36 0 浏览量 回答数 0

回答

php也确实推荐过不要使用mysql_xx来连接MySQL数据库。推荐PDO、MySQLi来连接管理MySQL。PDO扩展为PHP访问数据库定义了一个轻量级的、一致性的接口,它提供了一个数据访问抽象层,这样,无论你使用什么数据库,你都可以通过一致的函数执行查询和获取数据。注意,你并不能使用PDO扩展本身执行任何数据库操作,你必须使用一个database-specific PDO driver(针对特定数据库的PDO驱动)访问数据库服务器。PDO并不提供数据库抽象,它并不会重写SQL或提供数据库本身缺失的功能,如果你需要这种功能,你需要使用一个更加成熟的抽象层。PDO随PHP5.1发行,在PHP5.0的PECL扩展中也可以使用。PDO需要PHP5核心OO特性的支持,所以它无法运行于之前的PHP版本。mysqli是PHP对mysql新特性的一个扩展支持。在PHP5中可以在php.ini中加载mysql后面的i,指improved, interface, ingenious, incompatible or incomplete-可以和mysql_xxxx一样的方式使用-支持OO接口,简简单单调用-支持MYSQL4。1引入的新特性-通过mysqli_init() 等相关函数,可以设置高级连接选项
蛮大人123 2019-12-02 01:43:35 0 浏览量 回答数 0

问题

PHP Fatal error: Call to undefined function new Redis()

so问题地址 描述见图片 经测试 转义不能解决我的问题。 关于扩展,我在 phpinfo(),或者 使用 php -m ,或者在脚本内使用print_r(get_loaded_extensions());方法或者在 php cli 内 ...
天眼互动 2019-12-01 19:27:26 2125 浏览量 回答数 1

回答

这个要看php加载的mysql的扩展文件的路径是否也修改了
chuanshuolian 2019-12-02 01:45:35 0 浏览量 回答数 0

问题

打开php.ini文件中的 error_reporting选项导致mysql扩展加载失败,求助。

下载了一个项目的源码,运行时有很多的Notice级别的错误,于是在php.ini文件中的开启了error_reporting下的Default Value: E_ALL & ~E_NOTICE,但是发现,开启后会导致 Call to...
落地花开啦 2019-12-01 19:54:36 927 浏览量 回答数 1

回答

Rewordpress WPImageEditorImagick 指令注入漏洞 今天阿里云给我发短信说 wordpress 有漏洞 然后让修复,,然后让开通暗骑士专业版 最后我发现我压根没有装 imagick   php 扩展。。。。 php -m 可以看下 PHP加载的模块。另外我PHP的system函数也是被禁用的
爱乐促 2019-12-02 01:54:47 0 浏览量 回答数 0

回答

你的 php是5.4的,配合 mysql 5.5 是没有问题的,所以不要听别人什么“mysql版本太高”由于你的 mysql 已经卸载,而且是“结果就装不上去,卡死在安装的最后一步了”所以你还是需要先安装好 mysql,不知你的操作系统是什么mysql 不能重新安装,多半是原来没有卸载干净。需根据你的操作系统来寻求结局方案关于 phpMyAdmin 的 缺少 mysqli 扩展 的错误phpMyAdmin 可支持 mysql 和 mysqli 两种扩展,默认是 mysqli$cfg['Servers'][$i]['extension'] = 'mysqli';如果你不想加载mysqli 那么就改成 'mysql'
蛮大人123 2019-12-02 01:42:56 0 浏览量 回答数 0

回答

php 不懂###### 引用来自#2楼“酸汤鱼”的帖子 php 不懂  不懂可以学吗,我是做.net的,只要会一种编程语言,学其它的就好学啊,没有什么难的啊,只要用心学。###### 短标签建议还是关闭的好。还有书写的时候最好直接就不要写短标签。 一入门之入门贴... 还没加 apache,mysql,....###### 为什么extension=php_exif.dll放在extension=php_mbstring.dll之后?###### php_mbstring必须在php_exif前被加载 以下来自手册 扩展库 说明 注解 php_exif.dll EXIF 函数库 需要 php_mbstring.dll。并且在 php.ini 中,php_exif.dll 必须在 php_mbstring.dll之后加载。
montos 2020-05-29 23:51:05 0 浏览量 回答数 0

回答

php 不懂###### 引用来自#2楼“酸汤鱼”的帖子 php 不懂  不懂可以学吗,我是做.net的,只要会一种编程语言,学其它的就好学啊,没有什么难的啊,只要用心学。###### 短标签建议还是关闭的好。还有书写的时候最好直接就不要写短标签。 一入门之入门贴... 还没加 apache,mysql,....###### 为什么extension=php_exif.dll放在extension=php_mbstring.dll之后?###### php_mbstring必须在php_exif前被加载 以下来自手册 扩展库 说明 注解 php_exif.dll EXIF 函数库 需要 php_mbstring.dll。并且在 php.ini 中,php_exif.dll 必须在 php_mbstring.dll之后加载。
kun坤 2020-06-05 23:58:05 0 浏览量 回答数 0

回答

php 不懂###### 引用来自#2楼“酸汤鱼”的帖子 php 不懂  不懂可以学吗,我是做.net的,只要会一种编程语言,学其它的就好学啊,没有什么难的啊,只要用心学。###### 短标签建议还是关闭的好。还有书写的时候最好直接就不要写短标签。 一入门之入门贴... 还没加 apache,mysql,....###### 为什么extension=php_exif.dll放在extension=php_mbstring.dll之后?###### php_mbstring必须在php_exif前被加载 以下来自手册 扩展库 说明 注解 php_exif.dll EXIF 函数库 需要 php_mbstring.dll。并且在 php.ini 中,php_exif.dll 必须在 php_mbstring.dll之后加载。
kun坤 2020-05-26 21:17:46 0 浏览量 回答数 0

云产品推荐

上海奇点人才服务相关的云产品 小程序定制 上海微企信息技术相关的云产品 国内短信套餐包 ECS云服务器安全配置相关的云产品 开发者问答 阿里云建站 自然场景识别相关的云产品 万网 小程序开发制作 视频内容分析 视频集锦 代理记账服务 阿里云AIoT 阿里云科技驱动中小企业数字化