• 关于

    PHP版本

    的搜索结果

问题

linux更换PHP版本,多个PHP版本切换

idevcloud 2019-12-01 19:50:52 2991 浏览量 回答数 1

问题

linux更换PHP版本,多个PHP版本切换

a123456678 2019-12-01 20:11:52 3164 浏览量 回答数 1

问题

因PHP版本过高,程序无法使用,现需降低PHP版本?

携手游人间 2019-12-01 19:32:22 1269 浏览量 回答数 1

阿里云试用中心,为您提供0门槛上云实践机会!

0元试用32+款产品,最高免费12个月!拨打95187-1,咨询专业上云建议!

回答

IIS7示例 假设windows是win7 64位 下载各个版本的php: 我们将使用fastcgi模块,直接下载非线程安全(Non Thread Safe)的版本,效率比较高.x86是32位的,x64是64位的。 下载解压放到某个目录,比如: E:php7.0.3\ E:php5.5.30\ E:php5.2.6\ php.ini的配置这里就不说了,原来该怎么设置怎么设置。 步骤 1.打开IIS 7。 IIS最上层>处理程序映射 2.右边 添加模块映射 3.在弹出的窗口中 路径写*.php 模块选FastCgiModule,可执行文件是php目录下的php-cgi.exe 名称随便填,为了好记可以填php版本名称,然后确定。 再添加几次 把多个版本的php都添加进去 4.由于是点IIS最上层添加,而不是点某个网站添加,所以每个网站目录不会自动生成一个web.config文件。我们可以自己添加一个utf-8编码的web.config文件放到网站目录下,用于调用不同版本的php,不管有没有多个版本的php,都需要这么一个web.config文件,内容如下: 代码无法成功显示,所以只能截图了: 主要就是scriptProcessor(脚本处理器)路径不同,决定了调用了不同版本的php。 也很重要,先把所有版本的php都移除一遍(这里的"name=" 就是之前填的名称)。再add name=,确保调到的是需要的版本。 注意:如果这边remove只有3个,而实际上你加了5个版本的php的话,为了确保调用到正确的版本,应该把另两个加进去。 然后就可以了。有新站的话就把这个web.config拷到站点的目录里,再修改下scriptProcessor的路径就可以了。 我这几个php共用的是一个MySql,版本是5.6.24,能正常使用。 由于php不同版本间是不怎么向后兼容的,比如php5.6以后不支持mysql_函数连接mysql数据库,只支持mysqli_和pdo_*等,所以多版本共存还是比较有意义的。

quintin 2019-12-02 01:40:04 0 浏览量 回答数 0

问题

Linux下LAMP服务安装,访问localhost 404 Not Found 问题

杨冬芳 2019-12-01 20:20:51 1959 浏览量 回答数 1

回答

如何查看PHP版本? Php的版本控制一直也是一个比较棘手的问题,因为版本不同导致有许多功能不能很好的实现,所以当程序上传到空间的时候一定要对版本进行有效的控制,这样可以避免不必要的麻烦产生。那么如何查看当前你的php版本呢?下面提供两种方法帮你查看你的php版本。 使用phpinfo()函数,该函数就是用来显示php服务器的配置信息,在你的环境下创建一个php文件,在里面数据下面代码,然后执行就会打印出下面结果,可以清楚的看到,你当前php的版本,已经php、apache、mysql等配置信息。 <?php     Phpinfo(); ?> 使用phpsersion()函数,这个函数的原型是string phpversion(void);返回的一个string,本函数是返回php版本信息,创建一个php文件,输入以下代码,就可以在浏览器中看到返回的php的版本信息了。 <?php     echo phpversion(); ?> ------------------------- 用户根据自己的php版本选择包内对应的dll ------------------------- 回 3楼(kideny) 的帖子 小站 无所谓了 主要是有其他应用

小柒2012 2019-12-02 01:03:37 0 浏览量 回答数 0

回答

问题原因 1、未开启openssl服务 2、Apache和PHP下的libeay32.dll、ssleay32.dll的版本不一致 3、sdk版本过低 解决方案 1、未开启openssl服务 OpenSSL功能没有开启,打开了php.ini文件,找到了;extension=php_openssl.dll 这行代码,删除前面的注释 2、Apache和PHP下的libeay32.dll、ssleay32.dll的版本不一致 建议2个版本一致,在设置前建议先复制数据,避免修改版本时导致出现问题。 3、sdk版本过低 php语言sdk过低会出现兼容问题,建议下载更高版本php语言的sdk(必须5.5以上)。

保持可爱mmm 2020-05-05 16:40:03 0 浏览量 回答数 0

回答

修改php.ini中的short_open_tag参数变为On的方法【概述】本文简要介绍修改php.ini中的short_open_tag参数变为On的方法。【详细信息】目前只要php版本在5.3及以下,php.ini中的short_open_tag参数默认就是在On的状态。若之前php版本不是5.3或5.3以下版本的,可以在主机控制面板--高级环境设置--php版本设置处切换php版本(切换后需要等待1-2分钟生效);若php版本必须在5.4及以上的情况,不支持修改php.ini中的short_open_tag参数。【适用于】虚拟主机原文地址:https://help.aliyun.com/knowledge_detail/90662.html

1040441211520087 2019-12-02 01:14:35 0 浏览量 回答数 0

问题

php和客户端交互传数据问题

蛮大人123 2019-12-01 19:50:44 1182 浏览量 回答数 1

回答

网站手动配置还是一键包,php环境是什么版本 可以尝试切换版本,或者看下phpmyadmin是什么版本 不同版本支持的php版本不同 ------------------------- 回 2楼(小羽子) 的帖子 尝试切换版本

火蓝云 2019-12-02 02:12:36 0 浏览量 回答数 0

问题

可否更新下一键安装包内的软件版本为新一点的稳定版?

wofaday 2019-12-01 21:11:47 7847 浏览量 回答数 4

问题

世界上最好的语言,从 5.6.X 升级 7.0.X 指南

妙正灰 2019-12-01 21:02:55 6088 浏览量 回答数 3

问题

升级主机宝php版本

simol 2019-12-01 21:56:06 15 浏览量 回答数 0

问题

云虚拟主机主机php版本及MySQL版本

rosesonly 2019-12-01 19:04:18 420 浏览量 回答数 1

回答

详细解答可以参考官方帮助文档问题描述 使用万网Linux系统虚拟主机,如果php程序使用了zend加密,在程序安装后,访问网站报错如下:Fatal error: Incompatible file format: The encoded file has format major ID 1, whereas the Loader expects  问题分析 该错误原因是由于万网虚拟主机在php 5.2 版本使用的是加密组件是Zend Optimizer,但在5.3版本后Zend官方推出ZendGuardLoader代替了Zend Optimizer,如果程序中需要Zend Optimizer支持,在PHP5.3版本下运行会导致出错。此错误可以通过在万网虚拟主机控制面板(http://cp.hichina.com/) 平台高级环境设置>PHP版本设置中将php版本从5.3切换到5.2。注意:切换php版本后后大概需要5分钟左右生效如问题还未解决,请联系售后技术支持。

2019-12-01 23:21:54 0 浏览量 回答数 0

问题

轻量应用服务器,自动安装的wordpress,想请问下怎样升级PHP版本?

wu_chen 2019-12-01 22:05:20 15 浏览量 回答数 1

回答

解决思路 智慧云Linux版的php.ini存放在   php5.2版本   /usr/local/php5.2/lib/php.ini php5.3版本   /usr/local/php5.3/lib/php.ini php5.4版本   /usr/local/php5.4/lib/php.ini 你安装相应的版本编译 XSL  然后添加到 php.ini 配置文件里面  重启php-fpm进程即可

chinaccnet 2019-12-02 02:18:28 0 浏览量 回答数 0

回答

Rewin2008可以同时装php两个版本吗? windows iis 支持多个版本的php,7.0以上在 fastcgi里配置多个版本,6.0以下在isapi里配置多个版本。可以不同站点配置不同的php版本,也可以同一个站点配置多个php,不过这样你就得用文件名后缀来区分,比如 .php5.2 执行php5.2的fastcgi,.php5.4执行php5.4的fastcgi,不过这样很麻烦的说,还是不同站点配置不同的php吧。

第一应用 2019-12-01 23:18:24 0 浏览量 回答数 0

问题

主机宝的windows下的php版本可以更换吗?

风云动 2019-12-01 20:58:47 6655 浏览量 回答数 0

问题

主机宝的windows下的php版本可以更换吗?

风云动 2019-12-01 20:58:48 9424 浏览量 回答数 4

问题

如何升级php版本

aoohu 2019-12-01 21:25:41 8590 浏览量 回答数 5

问题

如何将我ECS上的PHP版本升级到5.5版本

仙人李 2019-12-01 18:55:29 452 浏览量 回答数 2

回答

折腾什么6啊, 这个php6还没php5.30来得新######回复 @彭哥 : 语法定型后小版本更新下api之类的,接下来估计重点是折腾php-jit之类的东西...话说,perl距离5的第一个小版本都快20年没出大版本了........######回复 @勇者天空 : 呵呵,这不意味着PHP到6不就断了吗######回复 @彭哥 : php4~php6是三架几乎同时的马车, php4是主版本, php5是稳定的"试验"版本, php6是测试版本. php官方准备把php6作为php4的下一个大版本发布的, php5仅仅作为语法过度, 后来玩php5的人实在太多了, 就把php6的特性作为php5.3合了进去, 所以别看php6版本看上高, 实际是几年前的老东西, 我建议装php5.3.13######那我就换个版看看######PHP6好多年没有更新了######是因为 从5.3开始 如果定义默认时区,调用时间函数和phpinfo时,就会报这个警告,可以不用管,不过建议定义一下默认时区;不管是在php.ini中还是,程序里面 ######听大伙这么讲,得了,我还是用 PHP Version 5.2.3算了,目前我就下载到这个版本的LAMP安装软件######推荐 Apache 2.2.22 + php 5.4.3 + Mysql 5.5.24 组合,已验证无问题。######6?官方都不建议6,最新版本5.3.13######5.4.n######楼主就是这样看提示的吗?都没看懂人家提示你什么就乱说,看看清楚人家提示你什么。######在php.ini配置文件的timezone设置里面去掉#号注释,后面加上参数 aisa/shanghai

爱吃鱼的程序员 2020-05-30 23:16:42 0 浏览量 回答数 0

回答

您好 您可以详细检查您的插件需要哪个版本的Zend.ZendGuardLoader 根据PHP版本不同有多个版本的加密器 可能需要更换PHP版本

西秦说云 2019-12-01 23:23:17 0 浏览量 回答数 0

问题

PHP和ZEND模块和缓存模块三者版本的问题

云代维 2019-12-01 21:39:20 9419 浏览量 回答数 1

回答

PHP有各种版本,不同版本之间可能存在兼容性,主要表现在mysql驱动、闭包等部分语法特性和系统函数的差异,PHP5.3并不是很高的版本,5.3以前的运行环境即使不是软件要求也应该主动放弃了,如果您的云主机PHP环境没有达到5.3以上是不合适的。 而同一ECS可以运行各种PHP版本,这并不会对ECS本身造成影响,更不会有压力。只要按要求更新一下PHP版本就可以。

望星星降 2019-12-02 00:40:44 0 浏览量 回答数 0

问题

现在服务器是php5.3,需要搭建一个5.4的版本,两个版本同时运行,端口不一样

云软微商城 2019-12-01 19:44:30 1166 浏览量 回答数 1

问题

ECS服务器如何升级php版本?

游客vizsfjvbpssme 2019-12-01 19:59:51 15 浏览量 回答数 1

问题

关于钉钉开发者模式对接本地服务器的一些问题(php)

奔跑在线上 2019-12-01 21:05:58 6591 浏览量 回答数 3

问题

PHP版本如何更换

夜光随行 2019-12-01 21:21:26 3720 浏览量 回答数 1
阿里云大学 云服务器ECS com域名 网站域名whois查询 开发者平台 小程序定制 小程序开发 国内短信套餐包 开发者技术与产品 云数据库 图像识别 开发者问答 阿里云建站 阿里云备案 云市场 万网 阿里云帮助文档 免费套餐 开发者工具 企业信息查询 小程序开发制作 视频内容分析 企业网站制作 视频集锦 代理记账服务 2020阿里巴巴研发效能峰会 企业建站模板 云效成长地图 高端建站