• 关于

    兼容ie

    的搜索结果

问题

兼容IE系列,FF,chrome的程序

落地花开啦 2019-12-01 20:04:58 909 浏览量 回答数 1

回答

关键看是否满足你的兼容需求 官方说的是兼容ie8+ & chrome & firefox 实际上ie8,9本身对css3和html5支持并不是特别好,所以这两个版本的ie多多少少还是有问题,需要一些其他兼容插件配合

杨冬芳 2019-12-02 02:44:57 0 浏览量 回答数 0

回答

浏览器渲染兼容性问题汇总:http://www.w3help.org/zh-cn/causes/大部分兼容性问题是因为历史原因,比如:IE6不支持border-radius和IE7/8不支持css3属性。然后是因为w3c的标准不够清晰或其他原因导致各浏览器厂商对标准的理解不同,例如:•各浏览器对常用行内替换元素的 'baseline' 位置理解不同•各浏览器对设定了 'min-height'、'max-height' 特性的元素生成的包含块的高度计算存在差异•各浏览器对使用 shrink-to-fit 宽度的包含块中行内元素后的绝对定位元素的静态位置判断存在差异•各浏览器对于未明确设定高度的包含块内包含百分比单位高度的块级元素或行内块元素的高度计算存在差异•各浏览器中 'min-width' 或 'max-width' 值单位为百分比的 IMG 元素的包含块的 'shrink-to-fit' 算法存在差异•各浏览器对未明确设定宽度的块级元素通过 margin 导致溢出其宽度为 0 的包含块时的宽度计算值存在差异最坑的是浏览器不按标准来,自己搞一套渲染逻辑。如:•各浏览器对 'display' 特性值的支持程度不同•IE6 IE7(Q) IE8(Q) 中 A 元素的 :visited :hover :active 伪类未按规范要求的算法来计算针对性•IE6 IE7 IE8(Q) 中对浮动元素上 'clear' 特性的解释出现错误,使其自身位置和其后浮动元素的位置与其他浏览器中不同•Chrome Safari 认为 'float:center' 是合法值且其计算值为 'none'感谢@Humphry的补充:这个站点已经不更新了,这里还有一份更加丰富的兼容性列表: http://en.wikipedia.org/wiki/Comparison_of_layout_engines_%28Cascading_Style_Sheets%29caniuse我也补充一下:现在前端开发很少再兼容IE6/7了。最新版的浏览器的css兼容性问题越来越小,各浏览器趋于一致。响应式设计的大量应用,导致兼容各种尺寸的屏幕和各种设备成了前端开发更重要的问题。

杨冬芳 2019-12-02 02:48:17 0 浏览量 回答数 0

阿里云试用中心,为您提供0门槛上云实践机会!

0元试用32+款产品,最高免费12个月!拨打95187-1,咨询专业上云建议!

回答

IE6我倾向于用温和的态度对付。用最小的精力,对IE6做最低限度的容忍。1.肯定做完再改。2.只维持IE6下最低程度的“正确”:不丢字、排版不出大的错位、重要功能不丢失。3.不追求样式一致。小的尺寸错误不管,样式不好IE6兼容的就退化处理。4.响应式也牺牲掉,IE6下只保证浏览器宽度够宽的时候说得过去就行。甚至可以把响应式的布局,IE6下通通退化成传统的px定宽布局。5.主要使用IE6条件注释和hack。hack手段主要是双下划线。6.表态抵制IE6并教育用户升级。我选择在网页页脚区的上边,插入一段黄底红字的提示。这样不影响网页正文区,又不妨害自己表态。7.如果像sf一样,受众比较“高科技”,不应该再用IE6来访问,则以上的IE6兼容都不做,并在网页的第一屏幕就提示。这里的提示不要吝惜嘲讽性的语言。例如:“如果您不是程序员中的垃圾货色,就不应该再使用IE6上网。如果您在公共场合,请用以下链接下载一个便携版浏览器(解压即用):Firefox, Chrome”。8.js方面,如果要IE6兼容,基本靠使用jQuery 1.x解决,简单省事。

杨冬芳 2019-12-02 02:47:23 0 浏览量 回答数 0

问题

IE6的兼容性该怎么调试?还是说忽视IE6了。

a123456678 2019-12-01 19:27:24 764 浏览量 回答数 1

回答

兼容模式是IE浏览器,一般内核就是ie7,ie8之类的,Promise是es6语法了,不兼容ie7,8。要兼容性好就在服务器端生成,而不是用客户端js 因为是要将echarts导出,echarts的直接转成base64的时候有个黑底,但是又不能简单的通过添加背景颜色去解决。我看了一下echarts渲染图表的节点,环形图是分了3个canvas在渲染,一个放背景颜色,一个放一些气泡动画,还有一个放图表内容。也就是我想导出的那个包含图表内容的canvas节点,是无法通过config去配置它的底色的。。。。也许改源码可以,但是这个超过能力范畴了。总的来说就是无论后台生成还是前端直接导出,我都要用到html2canvas去截这个图。但现在这个插件的代码在IE下面跑不下去。 另外为什么不用echarts自带的图片导出:一是因为除了图片还有一个pdf格式的需求,二是因为一个页面是由多张图表组成的,美工要求导出的文件排下版一起导出 楼主,解决了吗,我的也是这个问题,尝试使用了ie兼容补丁也是不行 你好?请问解决了吗?我现在也是使用html2canvas在360兼容模式下报错,另外保存如何将base64图片保存到本地。要考虑ie的兼容性。 楼主解决了吗?我也是这个问题,求解决方案 IE8调试了下,其中有句代码t.getComptedStyle(e,n)报错了,原因是ie8不支持getComputedStyle方法,改为e.currentStyle?e.currentStyle:t.getComputedStyle(e,n),是可以解决这个问题了,但是后面还有其他问题引出。暂时无解。

爱吃鱼的程序员 2020-06-23 14:11:47 0 浏览量 回答数 0

问题

Tapestry5.4 不兼容ie8, ie8 试了报错:RequireJS?400报错

爱吃鱼的程序员 2020-06-07 18:12:02 0 浏览量 回答数 1

回答

IE7 不支持CSS3,况且IE7几乎没人用,不要兼容了,现在兼容IE8以上就可以了。

tftaxis 2019-12-01 23:28:47 0 浏览量 回答数 0

问题

有什么方式在Linux下测试HTML对IE的兼容性?

a123456678 2019-12-01 19:55:06 1260 浏览量 回答数 1

回答

在2.0版本更新的时候,echarts的各种图表操作方法,都依赖于option的设置,没有setOption,clear或者resize等方法都会报错直接导致异常, 2.0.1已经修复了。至于数据更新的问题,没必要使用clear的,我之前也是这么做,跟林峰沟通后,他提示我看了setOption方法的第二个参数设置为true,就可以了。回复 @fengzhiguan:我遇到跟您一样的问题,需要缩放才行,不知道您解决么?回复 @democracy:为什么我在setOption后面加了true还是不行。。。IE8上面回复 @fengzhiguan:我饼图在IE8缩小了,在火狐正常,你的解决了吗?我现在用的就是2.01,你的意思是不用2.01版本么?回复 @黄小明186211:没有解决,没有更新2.0.1,只采用了2.0版本说了老半天。。。还是没解决IE8兼容问题啊,我看2.0.1版本上面针对IE8也是有问题的(具体问题为:显示空白,但是IE8浏览器用放大缩小功能后能正常显示)解决了么这个问题,请教一下,我也遇到你的这个情况,不知道怎么解决您解决了么这个问题?我相信大多数人都发现2.0.1对IE8不兼容,这里我推荐大家使用echarts1.4.1可以完美兼容,而且功能都很齐全,操作也一样 setOption方法的第二个参数设置为true 怎么弄??????? @NeoCD你那边的IE8兼容问题,解决了吗?我测试了一下,官网的demo在IE8下都出不来,如果用IE8以上的浏览器,使用兼容模式,只要文档模式不是IE9,同样也出不来,将setOption的第二个参数设置为true,还是如此。mychart.setoption(option,true) 通过把 animation设置为false和把 setOption方法的第二个参数设置为true还不能解决此问题的,可以通过ajax去请求url,然后通过 setTimeout来处理,具体可以参考下这个例子 http://www.daimahome.com/echarts-zai-ie8-xia-bu-xian-shi-tu-biao.html 博主,这个图在ie8显示不了 这个应该是用了Canvas了吧。基本上canvas是不对IE8及以下兼容了的。回复 @梦幻女侠:没有,不知道这种动态地图是不是不兼容ie8,一般的地图能在ie8显示(交个朋友么QQ:844146928)您好,我也遇到这样的问题,您解决了么问题解决了么?我也遇到这个问题了我是动态获取数据会出现在IE8界面空白,界面缩放之后显示,后来尝试静态数据可以,于是去掉数据获得的时候同步,IE8出现效果了,可能是数据同步或者异步的问题,不清楚这对你有没帮助。蛮试试。我也在学。 IE毒瘤   setTimeout(function( xxxxxxxxxxxxxxxxx ),100) 这样可以解决 IE8就不要调试le,IE8真的的是各种坑,现在你看IE8调试完,IE9,IE10,IE11都不一样可以用

爱吃鱼的程序员 2020-06-15 19:42:46 0 浏览量 回答数 0

问题

JavaScript获取元素节点,兼容IE低版本浏览器,但是IE7中无法识别ul标签下的li标签之后的span和a标签。

杨冬芳 2019-12-01 20:07:11 1131 浏览量 回答数 1

回答

Re阿里云论坛图片验证码不兼容IE10/chrome 刚试了,chrome是可以了呢···我之前不行的哎··· ------------------------- Re阿里云论坛图片验证码不兼容IE10/chrome 发自 Chrome ------------------------- Re阿里云论坛图片验证码不兼容IE10/chrome

thetcc 2019-12-02 00:28:59 0 浏览量 回答数 0

回答

object标签是要配合swf文件使用的。说白了就是要是没有swf文件的话,你是用不上object标签的。当然object标签是配合flash player使用的,两者缺一不可。至于为什么你的object代码无效,首先object有着两种写法,分别是兼容IE和非兼容IE的写法,要是想详细了解这两种写法就去下个flash然后发布,你会在发布后生成的html找到你想要的。顺便一提,你的object写法是兼容IE的,这意味着别想它在IE外的浏览器运行成功。再有就是width和height你没写,据我所知object的width和height默认是0。最后,你如果不去学flash,用不着管object!

杨冬芳 2019-12-02 02:52:37 0 浏览量 回答数 0

问题

【代码分享】站长可自定义设置网站使用哪种内核访问啦

浪漫淑女坊 2019-12-01 21:30:00 5297 浏览量 回答数 2

问题

如何可以用JS 设置IE兼容性视图

小旋风柴进 2019-12-01 20:25:57 1139 浏览量 回答数 1

问题

阿云浏览器如何默认为IE兼容模式

A553798931 2019-12-01 20:14:20 6979 浏览量 回答数 5

问题

ES5 Array新方法filter如何兼容ie

a123456678 2019-12-01 20:24:35 845 浏览量 回答数 1

回答

使用float布局的,不过使用float布局在ie6,7间存在兼容问题。使用display: inline-block布局,但是display: inline-block存在元素之间会有间隙,而且ie7以下的浏览器不兼容display: inline-block,需要写hack解决。使用flex布局,问题就是兼容性不好。

a123456678 2019-12-02 02:25:24 0 浏览量 回答数 0

问题

IE 和标准下有哪些兼容性的写法

茶什i 2019-12-01 22:02:57 14 浏览量 回答数 1

回答

有IE6/IE7/IE8浏览器支持CSS3属性的js吗PIE使IE支持CSS3圆角盒阴影与渐变渲染让IE6/IE7/IE8浏览器支持CSS3属性cssSandpaper-兼容IE的CSS3 JavaScript库

杨冬芳 2019-12-02 02:31:02 0 浏览量 回答数 0

问题

关于react antd组件兼容ie11的问题?报错

爱吃鱼的程序员 2020-06-05 15:04:28 0 浏览量 回答数 1

问题

javascript 存在IE FF chrome的兼容性吗?

落地花开啦 2019-12-01 20:05:07 953 浏览量 回答数 1

问题

如何测试各个浏览器兼容性 特别是IE

杨冬芳 2019-12-01 20:02:01 872 浏览量 回答数 1

问题

如何测试各个浏览器兼容性 特别是IE

杨冬芳 2019-12-01 19:40:46 1267 浏览量 回答数 1

问题

angularjs ng-options ie下的兼容问题 400 请求报错 

kun坤 2020-05-30 15:38:32 0 浏览量 回答数 1

问题

你知道vue2.0兼容IE哪个版本以上吗?

游客7iokfgo4yexey 2020-05-23 11:55:18 3 浏览量 回答数 1

回答

相当于CSS3 opacity 透明,而filter属性是IE特有的,它还有很多其它滤镜效果,而filter: alpha(opacity=0); 兼容IE8及以下的IE浏览器, 而在支持CSS3 opacity 的浏览器中,可以 opacity:0;你可以这样兼容性写法h1{ filter: alpha(opacity=0); opacity: 0; }

杨冬芳 2019-12-02 02:39:12 0 浏览量 回答数 0

问题

前端开发怎么能够很好地兼容火狐、谷歌、IE主流浏览器

不语奈何 2020-01-09 16:40:09 189 浏览量 回答数 3

回答

ie 11 可以兼容ie9模式运行的。  调整一下文档模式就行。 可以尝试兼容模式运行。 可以用ietester 降级是没法的。

玩站网 2019-12-01 23:13:05 0 浏览量 回答数 0

问题

怎样让bootstrap兼容ie浏览器,引用html5shiv.min.js无效:报错

kun坤 2020-06-14 06:42:27 0 浏览量 回答数 1
阿里云大学 云服务器ECS com域名 网站域名whois查询 开发者平台 小程序定制 小程序开发 国内短信套餐包 开发者技术与产品 云数据库 图像识别 开发者问答 阿里云建站 阿里云备案 云市场 万网 阿里云帮助文档 免费套餐 开发者工具 企业信息查询 小程序开发制作 视频内容分析 企业网站制作 视频集锦 代理记账服务 2020阿里巴巴研发效能峰会 企业建站模板 云效成长地图 高端建站