开发者社区> 问答> 正文

新人求助:关于IOS APP向下兼容的问题

a123456678 2016-07-20 17:16:47 997

开发环境:xcode4.6.3

SDK版本:IOS 6.1

问题描述: 在上述环境下开发的软件(APP),经过测试在IOS6.1以上的系统和真机上运行都是没问题的,但是如何在老版本的系统中(IOS6.1以下),正常编译执行?

同事的iphone4 系统是4.5的,就运行不了,开发的软件!如何让我的软件向下兼容那个而又不彻底重构代码的情况下,解决这个问题呢?

小弟我刚学IOS才一个月,希望各位大师指点迷津!不胜感激

开发工具 iOS开发
分享到
取消 提交回答
全部回答(1)
  • a123456678
    2019-07-17 19:59:04

    一般来说,SDK只会向下兼容2个版本,也就是说现在的SDK是7.0,那么自动会兼容到5.x和6.x,只要你在DemployTarget选一下就行了,然后自己控制好代码里的逻辑,不要用6.x Only或7.x Only,或者做好多版本的特殊处理。

    0 0

集结各类场景实战经验,助你开发运维畅行无忧

推荐文章
相似问题