关于linux下安装mysql的问题-问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文

关于linux下安装mysql的问题

2016-07-15 13:57:10 1831 1

一般安装mysql只要安装mysql-server和mysql-client就可以正常使用,
但是为什么还需要安装mysql-shared呢?
我知道mysql-shared-compat这个包是一个向下兼容包,但就是搞不懂
mysql-shared这东东是干什么的?

取消 提交回答
全部回答(1)
  • 杨冬芳
    2019-07-17 19:56:55

    MySQL-server-VERSION.glibc23.i386.rpm

    The MySQL server. You need this unless you only want to connect to a MySQL server running on another machine.

    MySQL-client-VERSION.glibc23.i386.rpm

    The standard MySQL client programs. You probably always want to install this package.

    MySQL-devel-VERSION.glibc23.i386.rpm

    The libraries and include files that are needed if you want to compile other MySQL clients, such as the Perl modules.

    MySQL-debuginfo-VERSION.glibc23.i386.rpm

    This package contains debugging information. debuginfo RPMs are never needed to use MySQL software; this is true both for the server and for client programs. However, they contain additional information that might be needed by a debugger to analyze a crash.

    MySQL-shared-VERSION.glibc23.i386.rpm

    This package contains the shared libraries (libmysqlclient.so*) that certain languages and applications need to dynamically load and use MySQL. It contains single-threaded and thread-safe libraries. If you install this package, do not install the MySQL-shared-compat package.

    MySQL-shared-compat-VERSION.glibc23.i386.rpm

    This package includes the shared libraries for MySQL 3.23, 4.0, and so on, up to the current release. It contains single-threaded and thread-safe libraries. Install this package instead of MySQL-shared if you have applications installed that are dynamically linked against older versions of MySQL but you want to upgrade to the current version without breaking the library dependencies.

    MySQL-shared-compat-advanced-gpl-VERSION.glibc23.i386.rpm, MySQL-shared-compat-advanced-VERSION.glibc23.i386.rpm

    These are like the MySQL-shared-compat package, but are for the “MySQL Enterprise Server – Advanced Edition” products. Install these packages rather than the normal MySQL-shared-compat package if you want to included shared client libraries for older MySQL versions.

    MySQL-embedded-VERSION.glibc23.i386.rpm

    The embedded MySQL server library.

    MySQL-ndb-management-VERSION.glibc23.i386.rpm, MySQL-ndb-storage-VERSION.glibc23.i386.rpm, MySQL-ndb-tools-VERSION.glibc23.i386.rpm, MySQL-ndb-extra-VERSION.glibc23.i386.rpm

    Packages that contain additional files for MySQL Cluster installations.

    0 0
相关问答

2

回答

Linux服务器安装Mysql报错

2018-09-30 06:44:55 2737浏览量 回答数 2

3

回答

Linux服务器安装MySQL报错

2018-09-30 06:51:40 2993浏览量 回答数 3

1

回答

[转载]Linux系统性能分析标准

2017-11-29 22:43:05 2104浏览量 回答数 1

8

回答

linux系统哪个稳定!

2015-07-13 01:17:13 5058浏览量 回答数 8

0

回答

Linux系统下MySQL数据库导出与导入操作

2011-12-30 07:09:22 8699浏览量 回答数 0

7

回答

【入门教程系列】Linux系统apache环境设置伪静态(适用于新手初级站长)

2011-10-29 14:58:55 16907浏览量 回答数 7

3

回答

我购买Linux系统的社区云套餐不会设置,谁能帮我

2011-10-04 09:07:53 7066浏览量 回答数 3

5

回答

请教个问题,LINUX系统apache如何支持中文代码?

2011-09-27 17:51:46 9052浏览量 回答数 5

31

回答

【入门教程系列】Linux系统建站完整教程(适用于新手初级站长)

2011-09-26 16:53:51 49512浏览量 回答数 31

8

回答

服务器打算用Linux系统,不知道那个版本的好用?

2011-08-31 12:17:47 8426浏览量 回答数 8
+关注
杨冬芳
IT从业
1
文章
9167
问答
问答排行榜
最热
最新
相关电子书
更多
低代码开发师(初级)实战教程
立即下载
阿里巴巴DevOps 最佳实践手册
立即下载
冬季实战营第三期:MySQL数据库进阶实战
立即下载