动态库的版本问题(libldap)-问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文

动态库的版本问题(libldap)

杨冬芳 2016-07-11 18:23:25 1337

程序依赖了libldap, 在makefile写了-lldap参数,连接报错找不到库,发现/usr/lib64下面是类似libldap-2.2.so.7这种命名方式,2.2-2.4都有,还有libldap r-2.2.so.7这种。
想请问一下,这些版本的兼容性如何,为何没有遵循so.x.x.x这种方式来管理版本问题呢?

分享到
取消 提交回答
全部回答(1)
  • 杨冬芳
    2019-07-17 19:54:33

    这个命名没有统一的标准,跟开发的人的观点有关

    一般都是通过建立软连接的方式来变成libxxxx.so使用
    screenshot

    0 0
+ 订阅

时时分享云计算技术内容,助您降低 IT 成本,提升运维效率,使您更专注于核心业务创新。

推荐文章