求问ubuntu 13.10下ns3.8安装遇到python2.7-config意外停止 -问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文
阿里云
为了无法计算的价值
打开APP
阿里云APP内打开

求问ubuntu 13.10下ns3.8安装遇到python2.7-config意外停止

2016-07-08 16:32:43 3451 1

运行./build.py时,报错说“对不起,应用程序i386-linux-gnu-python2.7-config意外停止”
所以就build failed,遇见错误的地方如下:

Build NS-3

Entering directory `./ns-3.8'
Note: configuring ns-3 without NSC
=> python waf configure --with-regression-traces ../ns-3.8-ref-traces --with-pybindgen ../pybindgen-0.14.1
Checking for program gcc or cc : /usr/bin/gcc
Checking for program cpp : /usr/bin/cpp
Checking for program ar : /usr/bin/ar
Checking for program ranlib : /usr/bin/ranlib
Checking for gcc : ok

Checking for program g++ or c++ : /usr/bin/g++
Checking for program ar : /usr/bin/ar
Checking for program ranlib : /usr/bin/ranlib
Checking for g++ : ok

Checking for program pkg-config : /usr/bin/pkg-config
Checking for regression traces location : ok ../ns-3.8-ref-traces (given)
Checking for -Wl,--soname=foo support : yes
Checking for header stdlib.h : yes
Checking for header signal.h : yes
Checking for header pthread.h : yes
Checking for high precision time implementation : 128-bit integer
Checking for header stdint.h : yes
Checking for header inttypes.h : yes
Checking for header sys/inttypes.h : not found
Checking for library rt : yes
Checking for header netpacket/packet.h : yes
Checking for header linux/if_tun.h : yes
Checking for pkg-config flags for GTK_CONFIG_STORE : ok

Checking for pkg-config flags for LIBXML2 : ok

Checking for library sqlite3 : yes
Checking for NSC location : not found
Checking for header sys/socket.h : yes
Checking for header netinet/in.h : yes
Checking for program python : /usr/bin/python
Checking for Python version >= 2.3 : ok 2.7.5
Checking for library python2.7 : yes
Checking for program python2.7-config : /usr/bin/python2.7-config
File "/usr/bin/python2.7-config", line 5
echo "Usage: $0 --prefix|--exec-prefix|--includes|--libs|--cflags|--ldflags|--extension-suffix|--help|--configdir"
^
SyntaxError: invalid syntax
Traceback (most recent call last):
File "waf", line 158, in
Scripting.prepare(t, cwd, VERSION, wafdir)
File "/home/daisy/workspace/eclipseWorkspace/ns3.8/ns-3.8/.waf-1.5.16-e6d03192b5ddfa5ef2c8d65308e48e42/wafadmin/Scripting.py", line 105, in prepare
prepare_impl(t,cwd,ver,wafdir)

取消 提交回答
全部回答(1)
  • 保持可爱mmm
    2019-10-10 16:10:45
    直接输入这个命令就好了  sudo apt-get remove python2.7			
    代码: $ ./configure --prefix=/usr/include $ make $ sudo checkinstall  然后,python2.7文件夹出现在/usr/include/bin、/usr/include/liclude和/usr/include/lib中,  输入  代码: $ python --version python 2.6.5  但是,却出现如下提示: [text] $ sudo apt-get autoremove 正在读取软件包列表... 完成 正在分析软件包的依赖关系树 正在读取状态信息... 完成 您也许需要运行“apt-get -f install”来修正上面的错误。 下列软件包有未满足的依赖关系: command-not-found: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 computer-janitor: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 computer-janitor-gtk: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 gdebi: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 gdebi-core: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 jockey-common: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 lsb-release: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 nvidia-common: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-appindicator: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-apport: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-apt: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-aptdaemon: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-aptdaemon-gtk: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-brlapi: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-cairo: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-crypto: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-cups: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-dbus: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-egenix-mxdatetime: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-egenix-mxtools: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-farsight: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-gconf: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-gdbm: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-glade2: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-gmenu: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-gnome2: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-gnomeapplet: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-gnomecanvas: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-gnomekeyring: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-gobject: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-gst0.10: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-gtk2: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-gtksourceview2: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-gtkspell: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-imaging: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-indicate: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-launchpad-integration: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-libxml2: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-newt: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-notify: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-openssl: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-pam: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-pkg-resources: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-problem-report: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-pycurl: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-pygoocanvas: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-pyorbit: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-rdflib: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-setuptools: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-simplejson: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-smbc: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-software-properties: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-twisted-bin: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-twisted-core: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-virtkey: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-vte: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-webkit: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-wnck: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-xapian: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 python-zope.interface: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 screen-resolution-extra: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 software-properties-gtk: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 ufw: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 update-manager: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装 update-manager-core: 依赖: python (< 2.7) 但是 2.7.8-1 已经安装			
    ubuntu系统的很多模块、管理都依赖于python2.7,最好不要卸载。 卸载会导致系统问题,且难以修复。			
    

    来源于网络,供您参考

    0 0
相关问答

1

回答

ubuntu 12.04 lts 安装 Mysql 报错,求助?报错

2020-06-22 18:25:31 559浏览量 回答数 1

1

回答

在Ubuntu上安装配置Nginx, PHP, MySQL,报错

2020-05-28 09:21:26 504浏览量 回答数 1

2

回答

ubuntu14.04安装无法安装mysql

2016-07-27 14:32:29 4434浏览量 回答数 2

1

回答

ubuntu中mysql无法启动,何解?谷歌度娘都查过了

2016-06-27 12:00:48 1566浏览量 回答数 1

1

回答

ubuntu下mysql无法启动?

2016-06-23 15:33:46 1985浏览量 回答数 1

1

回答

ubuntu14下php连接不上mysql,求大神指点

2016-03-18 21:18:36 2103浏览量 回答数 1

1

回答

Ubuntu12.04下使用QT4.8连接MySQL找不到驱动

2016-02-28 16:51:00 2637浏览量 回答数 1

1

回答

在ubuntu安装mysql有没有更好的方式。

2016-02-18 10:02:37 1539浏览量 回答数 1

1

回答

无法访问vmware内Ubuntu中的Mysql

2016-02-13 10:09:46 2303浏览量 回答数 1

1

回答

ubuntu中mysql无法启动怎么解决?

2016-02-06 17:49:25 1784浏览量 回答数 1
+关注
杨冬芳
IT从业
1
文章
9167
问答
问答排行榜
最热
最新
相关电子书
更多
低代码开发师(初级)实战教程
立即下载
阿里巴巴DevOps 最佳实践手册
立即下载
冬季实战营第三期:MySQL数据库进阶实战
立即下载