开发者社区> 问答> 正文

debian如何使用低版本的gcc?

a123456678 2016-06-22 11:26:14 932

我需要在我的debian jessie上安装使用cuda 6.5,但是出现了一个问题:

debian jessie的默认gcc版本是4.9,而cuda 6.5并不支持gcc 4.9及以上版本。

所以,请问如何安装低版本的gcc,并将其设置为默认GCC? 谢谢各位!

并行计算 C语言
分享到
取消 提交回答
全部回答(1)
  • a123456678
    2019-07-17 19:45:19

    docker 是个不错的主意,然而我非常不习惯它,所以给出另外几个方案:

    使用 lxc 装个低版本的 debian。有 template 可以直接帮你装好,也许还会有现成的镜像可以下载。
    使用 debootstrap 创建一个低版本的 Debian chroot。反正只是编译而已 chroot 也足够了。不过 lxc 也没多少额外的代价。

    0 0

集结各类场景实战经验,助你开发运维畅行无忧

推荐文章
相似问题