php版本的不同在用CI框架header或redirect遇到的问题-问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文

php版本的不同在用CI框架header或redirect遇到的问题

落地花开啦 2016-06-17 14:54:44 2124

比如:管理员后台的登入我是这么写的
screenshot
在windows的php5.3它是正常跳转到后台首页的!
但是在liunx的php5.2.17它会报错。
screenshot
再比如会员后台判断是否登入状态我是这么写的!
screenshot
//以上这些都是空值,当然会报错,上图:
screenshot
还有以及会员登入状态点击退出我是这么写的!
screenshot
它同样也会报错,和后台的登入报的错一模一样!
screenshot
注意:以上这些报错在本地笔记本上边都是可以正常运行的!
是否是服务器配置问题呢?

php版本问题 框架header php版本 head问题 框架add
分享到
取消 提交回答
全部回答(1)
  • 落地花开啦
    2019-07-17 19:42:46

    把报错的英文拿到 google 翻译翻译一下看什么意思,然后找输出的地方在哪里。在代码的执行流程的不同地方 var_dump(FILE . LINE);,然后根据输出判断出错的地方。
    检查所有 PHP 文件的编码和换行符,注意不要在 ?> 之后有任何字符。实在查不出来就把 PHP 文件后面所有的 ?> 删掉。

    PS

    $_SESSION['adminname'] = $where['adminname'];

    这一行应该放到 if 里面,否则算是有漏洞。

    0 0
开发与运维
使用钉钉扫一扫加入圈子
+ 订阅

集结各类场景实战经验,助你开发运维畅行无忧

相似问题
最新问题