开发者社区> 问答> 正文

linux 安装gcc 使用yum

终于换了个能联网的linux使用yum install gcc,出现错误:

安装遇到:

Error: Package: glibc-headers-2.5-42.i386 (crypto)

       Requires: glibc = 2.5-42 
       Installed: glibc-2.12-1.47.el6.i686 (@anaconda-RedHatEnterpriseLinux-201111171035.i386/6.2) 
           glibc = 2.12-1.47.el6 
       Available: glibc-2.5-42.i386 (crypto) 
           glibc = 2.5-42 

Error: Package: glibc-devel-2.5-42.i386 (crypto)

       Requires: glibc = 2.5-42 
       Installed: glibc-2.12-1.47.el6.i686 (@anaconda-RedHatEnterpriseLinux-201111171035.i386/6.2) 
           glibc = 2.12-1.47.el6 
       Available: glibc-2.5-42.i386 (crypto) 
           glibc = 2.5-42

怎么办

展开
收起
a123456678 2016-06-13 16:28:28 3129 0
1 条回答
写回答
取消 提交回答
  • Requires: glibc = 2.5-42

           Installed: glibc-2.12-1.47.el6.i686 (@anaconda-RedHatEnterpriseLinux-201111171035.i386/6.2) 
               glibc = 2.12-1.47.el6 
           Available: glibc-2.5-42.i386 (crypto) 
               glibc = 2.5-42
    

    应该的当前的环境不满足安装吧,先把requires中的包安装完全,再装这个

    2019-07-17 19:36:22
    赞同 展开评论 打赏
问答排行榜
最热
最新

相关电子书

更多
Alibaba Cloud Linux 3 发布 立即下载
ECS系统指南之Linux系统诊断 立即下载
ECS运维指南 之 Linux系统诊断 立即下载